App does not load when the Apollo Client Devtools extension is enabled

Briefly describe (1-2 sentences) the Bug you’re experiencing:
When I navigate to app.asana.com, it just shows the loading indicator and nothing more happens.
I already tried to reload the page with R and cleared caches.

Steps to reproduce:
Navigate to app.asana.com

Browser version:
Chrome Version 89.0.4389.82 (Official Build) (x86_64)

Upload screenshots below:

5 Likes

That should read: “I already tried to reload the page with Cmd-Shift-R and cleared caches.”

Yup, experiencing the same issue. Same error visible in Dev Tools.

When I log in with incognito mode, it works again. No error in the dev tools. Maybe I have to delete the caches more thoroughly.

1 Like

Also seeing this JS error. Viewing in incognito works…

Just tried clearing all sites data including third parties cookies and now I’m stuck at the login page
Capture d’écran 2021-03-17 à 11.48.32

Another update: I checked my currently installed chrome extensions and disabled them one by one. After I remove the Apollo client dev tools, Asana works again. I re-installed and removed the extension to verify several times. Maybe that helps others…

4 Likes

Hi everyone, thanks for your reports and apologies for any inconvenience here!

I’ve checked this issue with our product team and they confirmed this issue is related to the “Apollo Client Devtools” extension as @Martin_Ley correctly pointed out. In order to solve this, the best option will be to deactivate the extension and contact Apollo’s support.

I hope this helps! Let me know if you have any other questions!

1 Like