We couldn't process your email because it was sent by different domain

I’m trying to use the email to task feature, but I get the message:
“We couldn’t process your email because it was sent by gmail . com but your email domain is somethingelse . org. Please contact your email admin to update your mail server’s email settings.”

I’m using a mail forwarding alias that I’ve used since 1992.
It is perfectly secure use an alias with Gmail, or Google would not allow it.

Please don’t tell me “do not use an alias”, as that is not very reasonable. This is the first application I run into that is having a problem with an email alias and Gmail.com.

I see some old closed thread about “We are looking at a solution to fix using aliases with Gmail”, but that was from 2018.

What is your software looking at in the mail head to reject this?

Okay, there are more problems here with the forum interface, I tried to submit this topic and got an error about not using more than 2 link – I did not explicitly put any links, so maybe do not assume some formatted string is a link by default?

1 Like

Hi @Mark_Horn, welcome to the forum and thank you for the feedback!

Can you add the gmail alias from the Settings > Email forwarding, and create tasks from the email?

As for the number of links in the post, there’s a strict limit in first posts to block spams. I’m sorry about the inconvenience.
As you move up the trust levels (by creating your first post), you’ll have more freedom.