"Visit link" not appearing with long URL in text field

I have text field “URL” that I fill with URLs to other sites or apps. When I hover over the field, “visit link” icon appears and I can click to go to the URL. When the URL doesn’t fit in the width of the field “visit link” icon does not appear.

I am using Asana Business in a Chrome browser v. 114.0.5735.106

It works for task 1, but not for task 2

Is this a bug, or is it just me doing something wrong :smiley:

1 Like

Sounds like a bug indeed!

Hi @Herve_Buisset, sorry for the trouble. I’ve tested on my end with a very long link, and I can’t replicate this issue. Can you confirm if this happens in an incognito window too?

No trouble at all. I’ve tried it in an incognito window and had the same issue. I tried in Safari with the same result. In all instances I tried it in different projects.
My link has 77 characters.

Update: the link is:
https://mail.google.com/mail/?view=cm&fs=1&to=naam.voornaam@site.be&su=Task 2

I shortened it:

And it works

Hi @Herve_Buisset thanks for confirming that. We are still having trouble replicating this on our end, so we’d need some additional information to help our developers, if you don’t mind.

Can you confim if you are testing the same global field in different projects, or if the issue is affecting new test fields you’ve created too?

Also, can your colleagues replicate this?

I asked a colleague to do this and she got the same result. As we both use a Mac Mini, I tried it on a Windows Surface, and still gave the same result. I tried different fields. New ones, but to no avail.

I tried with the long and the short link:

Could the link be the issue? I have tried with long links to Google Drive and those work.

Hi @Herve_Buisset, sorry for the delay. This is super strange, especially because it’s only impacting this specific link. I’ve tested much longer links on my end there was no issue.

That said, my team has also tested your link on our end and it seems to be working fine. The icon still appears.

If this is only affecting this link, I’d recommend trying a URL shortener like Bitly. But let us know if the issue happens again and send me the examples so that we can take a closer look for you. :slight_smile:

Using an URL shortener may be difficult as this is a dynamic field.
I am looking for a way to send an e-mail from asana with the to and subject field pre filled.
Thanks for the follow up. I’ll keep on experimenting.

Oh, I see, thanks for clarifying, @Herve_Buisset, and I’m really sorry that we are not able to provide another workaround for now. This has been flagged to our developers anyway, even though we could not replicate, so if we see similar reports again, we will know it’s not the first time and will be able to look for patterns.

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.