Unable to open files attached to a task

Important note: To help us resolve your issue as quickly as possible, please ensure to fill out all the sections below. Do not share any private information such as email addresses or phone numbers - This is a public Forum!

Briefly describe (1-2 sentences) the Bug you’re experiencing:
When a file is attached to a task locally (“your computer” as the attachment option), you are unable to view this as it gives a 404 error. You can download the file with no issues, but viewing always produces this error

Steps to reproduce:
Create a task
Click the attach files button
Select your computer as the option
Select the file (a Word document is what I have used)
Attempt to view the file by clicking on the filename in the task
Receive 404 error

Browser version:
Using the Asana desktop app, however have attempted in Microsoft Edge for Business Version 120.0.2210.61 (Official build) (64-bit)

What version of Asana are you using (Basic/Premium/Business/Enterprise)?

Upload screenshots below:

A client of mine has the same issue, when they click the file it seems to redirect them to some internal address and fails…

1 Like

I re-read my discussion with the support, the answer was “this is a Microsoft Edge bug, we don’t plan on fixing it”

Does it go to a page like this? (see url)

Hi @Kosta_Michellis ,

I belive what Asana is doing is rather than saving a the actual file, they are saving a link to the file. (which is why you are seeing this error, since maybe the link has become invalid)

As such could you try reuploading the file (as that should update the link on Asana).

Hey Bastien,

Yes the URL is very similar to that. Ah okay, I haven’t done any testing in other browsers, but will test with chrome now. Did you have any luck with another browser?

Hey Harsh,

I have tried re-uploading the file and can confirm the error still persists. I also created a brand new task and uploaded a file and instantly attempted to view it and received the same error

I attempted with chrome and am also unable to view the file, however it doesn’t give an error, instead it downloads the file. Is that the expected behaviour or should we be able to view a word document without downloading it?

It is the intended behaviour, Asana only has an embedded viewer for images and PDFs