Timeline only loads after scrolling (project with 300+ tasks and 30+ sections)

Hello friends,

I have a project with about 300 tasks and 30 sections. At some point it started not loading/showing the all the sections, even though they are populated and expanded, unless I keep scrolling to them, in which case it loads one section at a time if i keep scrolling in that direction.

It happens in all my projects of similar size.

Sound familiar? It’s become quite a large time chunk of my work flow.

Chrome Version 87.0.4280.88 (Official Build) (64-bit)

Thanks!
Wes

2 Likes

Hi @Wes, thanks for reaching out!

The steps in this article usually solve this type of issues.

If this doesn’t help, I’d recommend reaching out to our support team following these steps: How to contact our Support Team ✉. if you could provide them with the info listed below, they should be able to look into this for you:

  • URL of this thread
  • URL of the project
  • Possibly a screencast (I’ve added some tips below), that would really help speed up investigations or at least screenshot illustrating the issue,

Screencast :
Loom is a great app for video screencasts: https://www.useloom.com/

In your video screencast, we recommend that you use a Chrome Incognito window and have your Javascript console open:

Try to include the entire browser window, including URL bar, in the video screencast.

Let me know if there is anything else we can help with!

1 Like

Hi Emily!

Thanks for getting back to me so quickly.

I tried it with an incognito window and the behavior was identical. I also checked my browser version and did the websocket test.

It really seems to be more of a programmed behavior than just a lag issue since it’s not just a matter of time before the sections load, they only load when i scroll up, one at a time. It’d be fine if i didn’t have 30 sections to load, but I have to scroll up, wait a sec for it to load, scroll up again, times 30.

Maybe i’ll try Support then. Thanks!
Wes

1 Like

They always ask to send a support ticket and nothing happens. I have the same issue, no action from Asana.

I also have the same issue.
Thanks for posting Wes and Ivan.
Many voices hopefully will help!
Steve

Thanks for the extra information @Wes! Unfortunately I don’t have the tools in the forum to have a closer look at this issue and identify the error as I can’t reproduce it. When you contact support and send them the screencast with the console open, can you confirm via DM the email address you used to contact them? I can liaise with our support team to speed up the process!

@Steven_Kopandy and @IvanStaykov please feel free to DM me as well and confirm this info! Thank you

1 Like

@Emily_Roman thank you so much for the support. I am passing on your offer however, since we talked extensively with them, I sent videos, screenshots and finally I kept receiving questions about browser versions, etc. We are basically working through it like this, I happens on all projects and it happens when you have a lot of tasks on the timeline. The bottom just does not load on scroll.

Hello @Emily_Roman,

I contacted support (Issue #277401) and they (Gabriel and Adan) understand the problem. It sounds like they are working on it:

“this seems to be related to a previously reported bug with a tool we use for loading tasks as they appear on screen, almost certainly triggered by the quantity of sections. It has loaded tasks in some of the sections around halfway down the timeline view, but not the sections at the top. What we’ve heard as a suggestion to address this is to try to re-organize your project for the time-being to include less sections.”

“We’ve gone ahead and had this brought to the attention of our Engineers to see what next steps may need to be taken. Once we receive a follow-up from them, we’ll message you right way”

Since this appears to be a confirmed bug, does it make sense to recategorize this thread?

Thanks!
Wes

2 Likes

Thanks for sharing @Wes! I’ve gone ahead and moved this thread to our #bugs category and added this thread to the bug report as well!

1 Like

Hey friends,

I just wanted to note the behavior has changed (a bit for the better) for me at least - not sure if it was something on the Asana side or not or how general it is.

Timeline still doesn’t fully load at first, but at least for me the section that starts loaded upon navigating to or refreshing Timeline is now closer to the top of the timeline than the bottom (previously it was near the bottom). I still have to scroll up to load a few sections at the top, which is still slow, but loading the “scroll down” sections is much faster.

Thanks if that was intentional! If it started loading all the way at the top (or just started with everything loaded) that would be even better!

Wes

Another observation if useful - I made a copy of my Project (33 sections) but only populated it with a small subset of the tasks. Many of the sections are empty. It loaded perfectly.

It seems to be more about the number of rows or tasks than sections.

Cheers.
Wes