Time zone incorrect after travelling

tasks

#1

After I have travelled through multiple time zones Asana doesn’t know the current day. Tasks due “Today” are still in the Upcoming or Later Queue and never move to Today. Tasks due earlier in the day still show as green.

Clocks on both the OS and Calendar programs (macOS/Outlook) are correct and nothing I have tried (restarts, etc.) gets this behavior working again.

A marked solution from Alexis on a similar issue refers to “browser’s time zone” - but browsers don’t have a timezone setting as they get it from the parent operating system. When this is wrong, where/how can this be reset/checked?


#2

Thanks for reaching out @Lex! I believe that timezones are automatically determined by your IP address; has yours been adjusted recently? or are you using a VPN by any chance?


#3

I thought @Marie was wrong for once, but Asana docs agree with her.


#4

@Marie The issue did eventually correct itself but it took about a day. I was not using a VPN. but had just returned from several international destinations in different time zones and I had the same problem there. So it seems to be IP that changes it, but with an introduced delay.

Please consider a manual setting for time zone, or at least a way to check what it is.

In addition to VPN, one can also use the internet on planes - and if someone (like me) wants to review their task list on a long haul flight, having the system unpredictably change the time zone, or stubbornly remain where I was instead of where I’m going, can be problematic.


#5

Thanks for following up and flagging this issue @Lex; I’m glad to hear that it eventually fixed itself! I can’t promise if or when this will be implemented, but I would recommend adding your vote to this thread from our #productfeedback category: Feature Request: Manually set and fix time zone