The result is too large. You should use pagination (may require specifying a workspace)!

I am trying to export project info as JSON. I am getting this error message, presumably because there is too much data:

“errors” : [ {
“message” : “The result is too large. You should use pagination (may require specifying a workspace)!”,
“help” : “For more information on API status codes and how to handle them, read the docs on errors: Build an app with Asana
} ]

Not sure what this means or what I need to do to get this file exported. Any ideas?

Note: I have almost no coding knowledge, so please keep that in mind when offering help. Thanks!


That should help: Build an app with Asana
If it is unclear, don’t hesitate to come back here :wink:



I too just started getting this and it makes no sense because I am using the Zapier integration of Asana, which has no pagination API options within it.

I’m defining the workspace and the project so it shouldn’t be having issues?

I have been totally fine with this integration for over a year now, and now it’s out of control with this same error. Any ideas? Is this something that Zapier needs to get involved on?


I think the issue is exactly what the message says: the requests Zapier is doing are getting too many results and Zapier needs to use pagination… which means Zapier (or Asana?!) should fix the zaps

Hey man, yeah it definitely sounds that way. This was the reply that I got from Zapier:

Thanks for writing in, and I’m so sorry for the headache here!

We’ve seen that this issue can crop up for folks when there are too many tasks coming back from Asana, and the vast majority of them are completed, which is what’s making the payload too large.

It looks like this issue is related to how many total tasks you have (including completed tasks). Typically, we handle large numbers of tasks by filtering or pagination, but unfortunately, Asana’s API doesn’t offer much in the way of filtering and we don’t support the type of pagination that they offer. Because of this, the Zap will continue to fail and unfortunately, there’s not much we can do about it. I’m sorry for the bad news!

Our best recommendation is to move any completed tasks in that specific project to another project, if possible. That should keep the number of incomplete tasks low enough for the Zap to function properly. Would that work for you here?

I’m also going ahead and adding your email to a list of folks who are getting affected by this error, so that we can notify you once there are any improvements with this!

Do let me know if you run into further questions here.

So essentially, sounds like the Zapier/Asana integration is just outdated and they haven’t gotten enough requests with people annoyed to fix it yet.

Pretty frustrating because this would be a simple fix if we were using the direct Asana API. Also pretty sure that the Asana/Zapier integration is managed by Asana, and they don’t have much concern at all about updating Zapier.

Definitely a frustrating boat to be in as an end user.


I don’t think this is the case; almost positive it’s managed by Zapier. See When will Asana have a zap "create project from template"!?!?! for a bit more.


Ah yes, I made a post asking Asana to take it over a few months ago:

So I guess that Zapier has to get a ton of complaints before they update their integration, sadly :worried:


Yeah - or Asana can decide to take it over. (They have a few more developer relations resources than they did previously, so one can hope…)



I just received the same error message. Did you ever managed to solve it somehow?

Use it to track new projects created in the organization.

Zapier has now turned off the “ZAP” due to the continuous error messages.

Has there been a solution to this matter that I have foreseen?
Any ideas that might help?


I have now posted a product feedback for this.

Hi @abass thanks for highlighting this issue with Zapier. Are you aware if the pagination issue is still around. We are doing a big roll out and want to know what to prepare for once we start building lots of tasks within the Asana project.

Genuinely not sure, haven’t messed with this in a while. Sorry about that!


There was work done on and improvements made to the Asana Zapier connector back in September. Unfortunately I wasn’t able to find any details on what was changed, so not sure if it involved pagination or not. I’m pretty sure Zapier is in charge of that connector, so you might want to query them on it.

1 Like

Thank you @Phil_Seeman and @abass I’ve dug further and read in an update from Zapier that they have resolved the issue. Thank you for your reply here.

1 Like

This error has just come up for me using Power Automate, so it’s still an issue there as well.

I’m getting this error as of today. Anybody else? Or any tips on workarounds?