Sort by Due Date in wrong order

Briefly describe (1-2 sentences) the Bug you’re experiencing:
When sorting in a project according to due date the Today at 8pm is after tomorrow
Steps to reproduce:
Open Project in list view
sort due date
Have task for today, tomorrow and today at a specific time
Browser version:
Chrome Version 80.0.3987.132 (Official Build) (64-bit)
Upload screenshots below:
image

Sorry to hear you are experiencing this issue @Paul_Grobler and thank you very much for taking time to report it in the Forum!

There is a Current Bug report regarding this topic son I’m adding yours to it.
In order to provide more information to the Team can you please confirm if this is also happening when using a different browser or an incognito windows? I’ve tried to reproduce it on my end but it seems to work fine for me.

Thank you for your help Paul! Looking forward to your reply!

1 Like

@Natalia I see the same behavior as Paul. I searched for the bug thread and couldn’t find it. Maybe you could add it here?

Just tried it in another workspace while in incognito and got the same:
image

Hello! I also am experiencing this bug. I have looked through the known bugs list and found this one, but I don’t think it’s the same bug exactly, since in that case the list is in fact sorted date (just not by time).

Here’s a screenshot of mine:

Worth noting that when I went through and added some due times to the tasks that didn’t have them, it fixed the problem. It seems to be when you mix dates and date:time values that the problem comes up, at least for me.

1 Like

@Natalia Since there is an previously existing bug thread per your comment, could you kindly move all these comments to that thread and provide us with the link? Thank you!

Hi @Stephanie_Oberg, sorry for the late follow-up here.

This is the only bug report thread we have in the forum for this issue but we have also a bug report sent to our development team including other users that contacted our support team. This is what Natalia wanted to mention :slight_smile: we added your report to the existing bug we have internally.

I asked for an update but we don’t have an estimate time to resolve this issue yet. Apologies again and I’ll make sure to update this thread as soon as I have more information!

These are related threads: