Some Project IDs and Task IDs not displaying properly on export

When I do an Asana export (I used Velocity - super useful) some of my Project IDs look like this:


And some of my Task IDs look like this


Now for us, Project IDs = CLIENT IDs - and TASKS = PROJECTS for that client.

In the FORMULA bar I do see the right ID - it’s in the CELL that I don’t.

Copy format from a different cell doesn’t work I figured out that I have to add an ’ to the beginning of the cell, convert cell to plain text, and then I’m able to take out the ’ and it will “stick”.

What could be causing this?

Is this likely to be something purely from within the sheet or could something in Asana be causing it? I don’t see any patterns with the clients/projects or the tasks.

Thank you!

Hi @KarenV, is this happening with different sofwares? Could you try opening your file with Excel and GoogleSheet and let us know if you’re experiencing the same issue?

Also, if you open GoogleSheet, what format (see screenshot below) comes us as default?

Looking forward to your reply!

FYI in my experience Excel doesn’t work for Asana IDs - it can’t handle the precision and mangles the formatting. Google Sheets has worked perfectly for me in regard to handling IDs.


Thanks for weighting in @Phil_Seeman!

Hi thanks @Marie and @Phil_Seeman for your help.

Just came back here to report and update.

BTW - this was happening in Excel and Google Sheets.

It happened again this morning and no amount of copying and special pasting were fixing the issue (Marie - I think the default was automatic - but I tried changing it to all kinds of different formats).

Here’s what fixed it: going from 2 decimal spaces to 0 decimal spaces (at least in Excel with this new file, fixed the whole column instantly.)

Hope you and everyone is healthy and safe.

EDIT: I spoke too soon. It turned the entries into a number, but on sorting I noticed there were a lot of duplicated #s. So something happens to the Task IDs when being converted or copying and pasting into new cells.

In Google Sheets also? I’ve not had issues with Task IDs in Google Sheets.

Hi Phil @Phil_Seeman yes it’s both…



Hmm, did you set the column to “Plain text” in Google Sheets? That format works for me. The IDs will be left-justified if you have it set that way, and it should display the whole ID.

(Don’t bother trying Excel - I spent hours trying every formatting possibility I could think of, and never got IDs displaying properly in Excel.)

Oops, that’s wrong - I had completely forgotten that I did figure out a way to have the IDs work properly in Excel! See: