Some Task IDs are incorrect on CSV Export

Briefly describe (1-2 sentences) the Bug you’re experiencing:
Some Task IDs on CSV Export don’t match the expected Task ID of the URL provided in “Copy Task Link” option.

Steps to reproduce:
Press project … → Export/Print → CSV

Browser version:
Chrome Version 73.0.3683.103 (Official Build) (64-bit)

Upload screenshots below:

That looks worrying. Did you look at the cell and see if there was some kind of formatting in place, like rounding up number or something like this? It’s a long shot.

1 Like

Hi @EljVek and thanks for reporting this issue!

In order to help us investigating this issue, could you please share the URL of the Project you’ve exported?

These ID’s look very neat (as in they have a loads of 0’s and end by 1,2,3); considering each task ID in the whole Asana is unique, the probability to have such a neat set of Id’s is beyond extraordinary!

Hopefully, looking at the project within our systems will give a piece of answer :slight_smile:

Thanks for your help, I look forward to your reply!

A regular ID looks like this " 1107608961464616". So my gut feeling is some kind of overflow because the cell is a number celle and your Excel does not know how to display such a big number. Try to change to a text celle instead…

@Bastien_Siebman @Marie,

It’s not an Excel formatting issue. Excel will display all Task IDs by default as “1.12E+15” since there are too many digits, but when viewing the direct cell the raw data will display the true Task ID number.

I should have expanded on my initial post, but I slightly modified the Task IDs in my example for privacy purposes. I reduced the number of digits down and changed the pattern such that the issue could be easily understood. In reality, my Task IDs are 16 digits long and differ greatly from one versus the other.

Ok :grin:

Thanks for the additional information @EljVek,

Could you please provide me the URL of the three tasks exported in your CSV above? This would be super useful to help us investigate this issue further!

Looking forward to your reply!

Hi @EljVek and thank you so much for providing me with additional details via DM!

I took a look at your project and can confirm there is absolutely nothing wrong with your task IDs. We recently modified our system for task ID’s (see Reminder about two big upcoming API changes (String IDs and new sections)) which might explain why you have a set of IDs looking very neat in this project, but I can confirm that generally speaking; ID’s are random and not necessarily follow each other!

Let us know if you have additional questions or comments; happy Friday!

I’m also seeing this issue. The task ID from the export is not matching the ID reflected in the Asana URL.

For example, here is a URL to a task in Asana: Log in - Asana

However, when I do an export that includes that task, the ID shows: 1126533934904030

All IDs in the export have had the last value changed to a 0.

Is this intended behavior? Should there be a difference between the ID in the URL to the actual task ID? I’m trying to use the export to create URLs to the task and that currently isn’t possible.

1 Like

I agree with you. There shouldn’t be any differences. The export feature isn’t useful unless these match.

After looking again, this seems to be an issue with Excel. When I view the export as text, the ID numbers are correct but when I open in Excel the numbers have been rounded.

Unfortunately, I can’t seem to get the Excel Data Import Wizard to pull and format the data correctly without the rounding.

If Asana has moved to string IDs, then that should be consistent in the export, meaning the IDs should have quotes around them. That would solve this issue.

If anyone knows the options that need to be selected in the Import Wizard to properly format the data without rounding they could share, I’d be grateful.

Sorry. One more post from me.

Workaround: Google Sheets can easily open the export and doesn’t round the numbers. You can then download as .xls and open in Excel.

To remain consistent, I still think Asana should treat IDs as strings in the export.

Excel might have an overflow on the number and display an incorrect value then… :thinking:

FYI, for anyone looking for a solution to importing tasks into Excel and retaining the proper ID values, please see: