Slack and Asana integration problem. We can't change the domain in asana bot settings

Hello!

We’ve started using slack integration on a free team workspace, we’ve mostly used our personal e-mails.

Afterwards we’ve switched to an organization and added e-mail accounts with our domain name.

Now half of the team isn’t able to set our current organizations workspace as a default Asana domain for Slack notifications to work.

We’ve tried to reinstall the integration, we’ve changed the e-mail address of users in Slack, so it’ll match the users asana e-mail address…
Nothing helps, it keeps sending the error message “We weren’t able to change your default Asana domain. Please try again.”

Please help resolving this problem

Hi there :wave:t4:

Thank you so much for posting your question on the Forum, I’m so sorry for the troubles.

Please note that you will need to de-authorize and re-authorize the app for it to function again.

Type the “/asana settings"; command and click the “Deauthorize” button. This will make it so you no longer are able to use the app and all of the linked project notifications you set up will be removed. If you want to turn them back on, you will need to re-authorize and set them up again.

To reinstall, click this page: https://asana.slack.com/?redir=%2Foauth%2F501772299766.8f52cf6233ade59a647ad133f8a4d5d1857b9f2d2cabf57736ca384ed1ff9634

Once you’ve tried this, and if you are still unable to get it to function please don’t hesitate to let me know so I can investigate further and escalate if needed.

Hope this helps!

1 Like