Send attachments via Zapier (Access denied)

content-marketing
attachments

#1

Hi there!

Whenever I try to send images attached to tasks via zapier to buffer I get an access denied message from asana. I add images via the download-URL provided by asana and I know it was possible a few months ago, when I ran tests to post asana tasks to my facebook page.

Anyone know how to get this to work now?

Best,
Martin


#2

I’m getting the same error on my side too… haven’t figured it out yet, but working on it! If anyone else knows, the knowledge would be great appreciated.


#3

You might want to report this to Zapier. Unfortunately, Asana doesn’t manage their Zapier integration. Maybe we can convince them to take it over?

There are a few bugs in it right now. For example, you can’t create a task with multiple projects tied in the current Zapier configuration. It’s just a bug and tough for Zapier to put all of the resources behind fixing them all. Asana’s team is far larger and would likely do a better job keeping their integration working and bug-free.

Zapier told me that if we can convince Asana to take over the integration that would be super helpful and would likely result in more frequent updates and fixes.


#4

ah, thanks for the info! Zapier + asana would be such a powerful tool!


#5

the frustrating thing is: it worked a few months ago!! :frowning:


#6

I think figured it out! You’ll want to add an additional action in your zap and use the custom value function that chooses the attachment id.


#7

Would you mind sharing a screenshot of how you did this?