Saved Searches (reports) not working correctly

I have two searches that have stopped working. Am using Chrome Version 90.0.4430.85 on Win 10.

  1. Create a search for tasks assigned to nobody (to find unassigned tasks). Worked yesterday, and returned 0 results when all were assigned. Today, it returns all tasks.

  2. Create a search for tasks incomplete tasks due in next three weeks. Sort by Due Date. Search results are correct, but no matter how many times I refresh, the sort is fairly random (some next week followed by some today followed by some later).

Upload screenshots below:

Hi @Patrick_Schmitz, welcome to the Asana Community Forum :wave:t2:

Thanks for flagging this! Firstly, could you please try the troubleshooting steps listed below to see if any of these help?

Looking forward to hearing back from you! :slight_smile:

Hi –

Cleared cache, logged out and in, disabled extensions, etc. Still got same behavior.

Tried this in MS edge, got same behavior. Something seems to be messed up on the back end…

Patrick

I’ve also tried starting over, and even modifying a standard report like “Tasks I’ve Created” to just show incomplete tasks sorted by Due Date, and the sort is all wrong. The first dozen or so are all soon, but out of order. On a related note, each time I refine a search, the sort reverts to last modified. I have to re-set the sort to Due Date to get what I want – this should be sticky.

The calendar view works, but it is clunkier and I prefer the list.

This is maddening – I use this to plan and I cannot reliably see the tasks that are due soon! I’ve been using Asana for years and never saw this before. It’s just in the last week that this started happening.

Hi @Patrick_Schmitz, thanks for following up here.

It looks like there was a bug with Advanced Search last week so this could have contributed to the issue you were having!

Are you still experiencing the same issues or have they since been resolved?

Bugs are still there. I tried hard refresh, etc., tried it in another browser, etc. but

  1. a search for unassigned tasks (assigned to “Nobody”) still returns a long list of tasks assigned to me, and

  2. a search for tasks due in the next three weeks, sorted by Due Date is not sorted correctly (the first four in the list should be later in the list as they are due late this week, but the rest are properly sorted from last Thursday through later in May).

I tried other variants on sorting a bunch of tasks by due date, and get similar behavior of the results being not in the correct order.

I can provide the actual saved reports if that helps – I assume someone can go in and see how I defined them and try to reproduce them.

Patrick

Thanks for getting back to me here, @Patrick_Schmitz.

In this case, I think it’s best to reach out to our Support team, with your search parameters and some screenshots if possible. The Support team has access to tools we don’t have here on the Community team and would be better equipped to get to the root of the issue!

You can reach out by following the steps below:

You can also provide the URL link to this thread so you don’t have to re-explain the issue! :slight_smile: