Rules not triggered by tasks assigned via a Template 2.0

Briefly describe (1-2 sentences) the Bug you’re experiencing:

Tasks created & automatically assigned by using a Template 2.0 are not triggering rules in My Tasks.

(Side note, I’m not certain if this is a bug, or if it’s expected behavior due to how T2.0’s currently work. If the latter, are there any plans to try to change this behavior in the future?)

Steps to reproduce:

I have a rule set up in My Tasks to add all tasks that are added to the Recently Assigned section into another project (and then move those tasks to another section in My Tasks). The rule is set to “Allow this rule to be triggered by other rules”. The rule continues to work correctly for all other tasks assigned to me (by a person or by a Rule).

We upgraded one of our templates to Template 2.0, and added in the specific assignees. On May 28th we used the template for the first time; tasks & subtasks were correctly assigned to me, per the template, but none of those tasks were added to the designated project nor moved out of the Recently Assigned section in My Tasks.

To test this again, I created a new private template (in the same team as the onboarding project), added a task that was assigned to me, then used the template. As before, the task stayed in Recently Assigned - my rule was not triggered.

Browser version:
(I’m using the Asana Mac desktop app, but:) Microsoft Edge 101

Upload screenshots below:




Hi @Aidan_Boling, thanks for reporting this and sorry for the trouble! I’ve gone ahead and escalated this issue to our Product Team, so we can investigate further and confirm whether is working as expected, or it’s a bug. I’ll let you know as soon as I have any updates!

If this is confirmed to be expected behaviour we have to document it in Project templates V2: what we gain, what we lose cc @Phil_Seeman

1 Like