Rule name length causes inability to edit title if too long

Hi there,

I think this is more of a bug or an unintended issue but I cant post it in the bugs section so it has to go here. Feel free to move this if its not in the correct spot.

The issue:
If a project rule name is too long, the button to edit the rule is cut from being displayed. This means that once you have saved a rule you can no longer make edits to its title.

Attempted fix:
Resizing app window
App restart
Web browser use
Resizing web browser - Note that this does allow me to extend the range of the title by spreading the browser in window mode over two screens and even beyond. But even here I hit a limit at which I was able to drag the browser window width. My example was intentionally obtuse to illustrate the point which did not bring back the edit button.

Suggested change:
Edit button should be locked in place regardless of title length, or made to appear on hover; however this would cause issues on mobile if the same elements are used bts.

Rules should have titles and descriptions. I may wish to set a generic title such as ‘Rules governing task completion’. If I wanted to make a full description of the ‘if-this-then-that’, I am unable to do so due to the title length issue described above.

Deleting a rule and recreating without having a built-in copy rule feature is not an option. Hypothetically, a lot of work could be done to a rule and the title changed after this, thereby leaving the rule stuck with the lengthy or even unrelated name. Recreating a rule (specifically one that has had a lot of configuration done to it) would be counter intuitive to Asana’s product intention of reducing administrative tasks.

If I’m missing something please let me know but so far nothing I’ve attempted has worked.
-B

Hi @BenjaminG, sorry to hear about this trouble! I tried to replicate this on my end, but the “Save” button seems to be working fine both on the desktop and web app, despite the length of the rule’s title.

Do you experience the same problem on both the desktop and web app? Please test in an incognito window and reinstall the Asana app. If the problem persists, I recommend reaching out to our Support team and sharing a screencast. They have the tools to investigate this specific case for you :slight_smile:

Reinstalling didnt fix the issue. Full system restart after too

Hi @Vanessa_N , I think @BenjaminG means that the ‘pencil’ icon to edit the actual name of the rule gets cut off when the name is extremely long.

I personally wouldn’t deem this is a Critical bug since this appears to be an extreme edge case.

@BenjaminG , I’m curious, is this issue disturbing your workflow or how you use Asana?

Yes @Richard_Sather that is a good summary. I would agree its not a critical bug, but is a bug (at least with me) nonetheless.

The issue disrupts the workflow in the sense that others needing to edit rules or see what they do cannot read the full title, therefore requiring more effort on their side, or a more in depth conversation than maybe there needs to be without this presenting.

I submitted a support ticket (1185903) and attached a narrated screen capture to help illustrate the issue. Oddly enough I discovered that growing the Asana app (in window mode) horizontally allows me to scale past the end point of the long title and the pencil icon reappears. A browser window doesn’t allow this though as it reaches a hard stop to which the window can be extended horizontally.

After discovering this, I was able to fix the offending rule via the app window extension method but the bug is still present in a general sense. So there is a solution, albeit a rather ‘janky’ method.

Thanks for the additional info, @Richard_Sather and @BenjaminG! I apologize for the misunderstanding.

@BenjaminG, I see that your request is queued for our Support team. They are currently handling a high volume of cases, but once your ticket is assigned to an agent, they will be able to escalate the issue to our Product team directly. :slight_smile:

1 Like

Thanks for the explanation @BenjaminG .
It may be an idea for Asana to insert a ‘rule description’ field that could be used for lengthier notes, rather than the Rule title itself! Just an idea that you could post in the Product Feedback category.

1 Like

I’ll follow up there with the description suggestion.

To follow up here, this was identified by customer support as a bug and was escalated the engineering team.

1 Like