Recent email security update. How to fix “We couldn’t process your email”

Add my company to the list of G-Suite users affected.

1 Like

Hi,

It is not even alias domain, the mail is being sent from primary_domain. But Google when send the email, it is being sent from “google.com” instead of “primary_domain.com”.

It affects mails being sent from “gmail.com” as well as “GSuite” mails.

I’ll chime in because this is becoming a real problem. I now have to copy email conversations as comments because we can’t just email to the task since we use an alias. It is at the point that even though I am an ambassador for Asana, have been using it for almost 7 years with the different positions I’ve held, I convinced my non-profit to PAY for the subscription (not an easy task at a non-profit) the extra workload this has created for me is no longer worth the program. So if it is not fixed, I’ll be convincing my superior’s to make the switch to a software that allows us to email in to it.

Really frustrated!

We switched from self-hosted Postfix to AWS-SES. We use a verified SES identity domain with DKIM and Custom FROM domain, as suggested in your post. However, we still see this error. Happy to share example email headers via PM.

Clearly there are steps or checks missing from this guide when using SES. What other considerations must be taken?

This is crazy. 2020 and this still has not been given a whitelisting option? Switching my alias and primary accounts is not an option.

Any solutions for emails sent from NetSuite?

" We couldn’t process your email because it was sent by netsuite.com but your email domain is XXXXXXX. Please contact your email admin to update your mail server’s email settings."

Another Gsuite user. Weird thing is that it’s been working fine for months before today. Did no changes on Gsuite.

3 Likes

I’m a GSuite user too I have been using this non-stop for about 12 months then suddenly today it is not working.

2 Likes

This has changed for us today when we’ve been fine using it for months. Did we receive another update that is preventing the emails from being sent?

1 Like

Same here. We have been using for 2 years on GSuite and suddenly doesn’t work. No aliases being used and no changes on our end

same here!

Well, seems like all good things come to an end! Can’t get tasks created via simple forwarding

Hi, I was experiencing the same problem today (May 1st, 2020) I went to https://toolbox.googleapps.com/apps/checkmx as another user in this thread suggested (Neal),. There was indeed a problem with our SPF record in our DNS zone. Followed the instructions mentioned in https://support.google.com/a/answer/33786 and it works now.

4 Likes

I’m not following the GSuite option. I have a G-Suite account. There is one email address associated with that account (mine). I only send emails to Asana from that address.

As ubiquitous as Gsuite is, I’m surprised that this isn’t fixed yet.

1 Like

It seems to have worked for me as well

1 Like

thanks for this! working now

1 Like

Thanks Christian and Neal… I got my hosting company to follow the instructions and it resolved the issue. Thanks very much!

1 Like

This worked brilliantly - thank you!

1 Like

Hi. I have trouble with sending task via email from our company domain. I´d like to send a task to specific project (x+project ID@…) and getting the following error " 511 Sorry, no mailbox here by that name (#5.1.1) (in reply to RCPT TO command)".
The only a way is to send to “My Tasks” x@mail.asana.com.
Any suggestion? Thank you.

Hi There. I’m trying to create new tasks in Asana or reply to an existing task comment via email but I’m getting this error message

“We couldn’t process your email because it was sent from a server that is not authorized to send emails for my domain.com Please contact your email admin to update your domain’s email settings.”

I’m using G Suite for emails.