Receiving a new error "Error: connect ETIMEDOUT 52.70.61.144:443"

Hi there,

Today I’ve started getting an error on some scripts I run every hour that outputs multiple times:
Error: connect ETIMEDOUT 52.70.61.144:443
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1106:14)

I’m using the latest version of Node.js Asana package and these scripts haven’t been changed in a few months. The methods I use in one of the scripts are:

  • tasks.findByProject
  • tasks.findById
  • tasks.removeTag
  • tasks.addTag
  • tasks.removeFollowers

I’m not entirely sure which method has the issue is occurring in as it the above error is all I get. It seems to work half the time on my local machine but on my linux server (Ubuntu 14.04.6 LTS). My local machine is using Node v10.15.1 and the server is using v10.16.0.

Any ideas would be much appreciated.

After further investigation I’ve found a few more facts:

  • The issue occurs when the first request is made to the API (I can instantiate the client in the Node.js script, but can’t seem to request anything)
  • I created a test script that just had the Node.js Asana package in it and ran just the tasks.findByTag method and it gave me the same error
  • I tried using a different API key on the scripts, but still the same error
  • I wondered whether it was something to do with the settings of my server or perhaps the API blocking my server in some way, so I retrieved a backup of my server from 7th Feb and created a new server with with that backup (all files and settings are identical) but with a new IP. Running all affected scripts no longer returned this error so it seems that the API is blocking the server IP

Is there anyway to understand if my IP is being blocked by the API? Are there any limitations that I’m not aware of that can cause this? I can share the server IP via a DM if needed

For now I’ve stopped all scripts from running that were affected just to stop anymore requests being made to the API from the server IP. Also, FWIW I am trying to work with an account that is at “Premium” level, so I assume there should be higher limits to requests using the API as described in the documentation?

@Ross_Grambo would have to reply regarding any potential IP blocking.

Correct!

1 Like

Could you DM me the IP and the ID of the App/PAT you’re using?

1 Like

Thanks @Ross_Grambo just sent you a DM