Newlines double when editing task descriptions in Asana mobile (Android)

Important note: To help us resolve your issue as quickly as possible, please ensure to fill out all the sections below. Do not share any private information such as email addresses or phone numbers - This is a public Forum!

Briefly describe (1-2 sentences) the Bug you’re experiencing:
In the Asana mobile app on my Android phone, each newline gets doubled about every 5 seconds when trying to edit a task description. This has been happening ever since the new editor experience was released for task descriptions (so several months now).

Steps to reproduce:

  1. Tap to a task in Asana mobile app (Android)
  2. Tap the task description to open the editor experience
  3. Type some text then press Enter twice to start a new paragraph
  4. Type more text as this second paragraph

At this point, you should notice the gap between the two paragraphs consistently growing as you type. Additionally, the cursor jumps a few characters back each time the newlines double. It’s basically impossible to edit task descriptions.

Note that this happens even when simply trying to edit a task description that already contains newlines.

Browser version:

  • Mobile phone is running Android 13
  • Device is a Samsung Galaxy A13 5G (SM-A136U)
  • Asana app version 7.41.5 (7410500)

What version of Asana are you using (Basic/Premium/Business/Enterprise)?
Free Asana (Basic)

Upload screenshots below:

Hi @Michelle_Blanchette, sorry for this trouble! This is a known issue and has been escalated to our Mobile team. According to our Developers, it seems to be rooted in a particular feature built into Android on Samsung devices. They unfortunately don’t have a solution for this problem yet, however, there is a workaround that can be helpful:

Go to your Samsung device Settings > General Management > Samsung Keyboard settings > Suggest text corrections > manage Apps and disable Asana from the list.

I hope this helps! :slight_smile:

Oh, wow! It’s now working perfectly since disabling that setting on my phone, like you suggested.

Thank you so much for this workaround!

1 Like

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.