Multiselect won't work with any integration

Hey Asana,

I am trying to integrate a project with Typeform. While there are 2 different ways of integration (A native one, built by Typeform for Asana, and a Zapier one), neither of them work with the Asana multiselect field. This is a real productivity killer for us. They initially seem to integrate but I submit my Typeform and get an empty field on Asana. Is there any plan on addressing this issue any time soon?

Thank you,


@ntemposd, I ran into the same issue recently and discussed it with Typeform’s support team. They said they would update their support article to clarify that their integration was not compatible with Asana’s multiselect fields. I did not get the impression, however, that they would be offering a new integration anytime soon. Instead, you will need to use an intermediary service like Zapier to connect your Typeform responses to your Asana custom fields. There is a bit of work on the backend that you will need to do as each custom field input has an Asana ID that will need to be matched with each Typeform response.

Hey @GregB,

Thank you for your answer. I’ve tried Zapier as well but seems like not working. If you’ve fixed it I’d appreciate a little more help.

I have just 1 multiselect Typeform question called Select both with two options A,B and an Asana multiselect field called Test with two options A,B

This is what I see on Zapier as possible values for integrating with my Asana Test field.

1. Submit date 2023-02-16T22:33:03Z
1. ID (Submission Token) d39jlshvsyn3d5fuzhg39jua0eotrs61
1. Form Responses ### Select both A, B
1. Form ID dc0GVmEM
1. Time to complete the form in HH:MM:SS.msec format 00:00:02
1. Select both
1. Select both (B)
1. Select both (A)
1. Field A4 T41 Pohm Tcd A, B
1. Field A4 T41 Pohm Tcd He1 Ln5 Vzlz Zs A
1. Field A4 T41 Pohm Tcd Mq Keunnw Mb La B

I’ve tested all possible combinations. While it seems successful I received an empty Test field, even when I select to just send (B). This is why I believe that the issue is on Asana and not on any of the integration providers. Zapier seems like sending the response but Asana wouldn’t receive it. On the other hand, both the native and Zapier integrations work like a charm with a single-select Asana field.

Any idea?



What worked for us is creating the workflow within Zapier with (1) Typeform as the trigger, then (2) Formatter By Zapier as an action, and then (3) Asana as an action. Using Formatter By Zapier’s Lookup Table function will let you translate the results from Typeform in a way that Asana understands (e.g., Green (the Typeform result) = 1343242343434 (the Asana ID) and Red = 1343242343435).

Hope this helps!


I’m running into the same issue here. I’m using the following in Zapier:

  1. Trigger: Updated Task in Project in Asana
  2. Action: Lookup Spreadsheet Row in Google Sheets
  3. Action: Update Spreadsheet Row in Google Sheets

Everything syncs over fine with the exception of the multiselect fields. I have attempted using the Formatter and trying to parse out the relevant values, but that doesn’t work either.

In my mind, we should be able to connect / extract these fields in the same manner they are downloaded when you do an export from Asana, one field with potentially multiple values separated by a comma.

1 Like

Hello folks,

Zapier and Typeform are both third-party integration, so there isn’t much we can do on our end. I recommend contacting their support team and requesting that they add multi-select support!