@mentions giving generic results before filtered view

I’m currently experiencing an issue with the filtered lists of users and tasks that appear when I start to add an @ mention. Before giving me a list of filter options based on what I’ve typed, it first presents a list of options unrelated to what I’m typing. This is most pronounced in trying to @mention someone in a task comment.

Steps to reproduce:

  1. Create a new task
  2. Go to the comment panel
  3. Type @
  4. A message appears saying: “Mention a teammate or link to a task, project, or message”
  5. Immediately type any letter
  6. For a brief time, a list of mention options appears that is totally unrelated to the letter that has been typed.
  7. The list of mention options then refreshes and is replaced with one actually filtered by the letter that you typed.

The really quirky bit:
There seem to be 2 default lists that first load. There’s one list of mentions that show up if you type @ and then a letter immediately afterwards. There’s a different list of mentions that show up if you type @, wait a couple of seconds, and then type a letter. Different list - but still totally unrelated to the letter that you type.

The problem here is that the unfiltered list will remain even after typing several letters. We’re a small organization so if I type “@steve” and hit Enter, I’d expect it to have filtered to the Steve that is in our organization. If I don’t wait for a second or two after typing “@steve” before I hit enter, I’ll end up with a mention to someone unrelated.

Browser version: Confirmed in the latest versions of Edge and Chrome

Upload screenshots below:

Hi @Marc_Baron, sorry for the trouble! I haven’t been able to replicate this issue on my end. We did have a similar issue recently, but our team has since fixed it. Can you confirm if this happens when you use Asana in an incognito browser window?

I believe I’ve had the same issue for a while as well, it would result in me tagging the wrong person because the view changed after I typed Enter…

1 Like

Hi @Vanessa_N - I’ve tried in a couple of browsers and in incognito and I’m getting the same behaviour in all cases. I’m in a second organization as well and it gives the same issue when I try it there (but with different default @mention lists)

We’ve been having the same issue in my org. We’ve got team members on Chrome, Safari, and within the desktop app and we’re all experiencing this.

I honestly never thought to submit this as an issue but this has been a thing for me for a while as well.

I’ll usually type the first 3-4 letters of a name, wait for Asana to show the name, click enter, and then see someone else was tagged. The last one was typing “D’ar” and hitting enter and “Valeria” was tagged.

@Vanessa_N, we have similar issues. Where you start typing a specific team member in the mentions and a list of unrelated names comes up, leading to similar problems that @Marc_Baron is experiencing

I’m also having the same issue. I thought it was just some sort of lag, but glad it’s not just me!

Hi everyone, thanks for the additional information. I have escalated this issue for investigation and as soon as I have updates I’ll post them here. Let me know if you need anything else in the meantime!

1 Like

When we type @ and then start typing a teammate’s name, it autocompletes with the wrong person’s name.

For example, if I type @jodi, @carol will be what Asana suggests / autofills.

Because it’s worked so well in the past, we’re all used to typing shortcuts super quickly - I’ll type @k + enter because for years that would automatically mention my coworker Kim. But now if I type that it @mentions my worker Lori, which doesn’t make any sense, and is slowing us all down.

This is a new issue happening fairly consistently for our team in the last two weeks or so.

We’re all using Chrome and Asana Premium.

I saw two threads here with similar topics from 2018 and 2022. Both had an Asana response about it being a bug that got fixed, so I’m hopeful for a similar resolution here!

Welcome back, @Jodi_Egerton,

I’ve merged your post into an existing thread about the same (I think) but for which a fix is currently in progress.




I have this same issue, and I can’t remember a time when it actually worked the right way. I go back and forth between tagging people in Slack and tagging people in Asana, and Slack always gets it right, but Asana not so much. I went to @ Julie this morning and it tagged Autumn instead. I think the system is pulling up the most common @ mentions first (I have tagged Autumn in a lot of tasks over the years) and then suggesting based on the actual letters, but it’s often the case that I type out someone’s name completely (Julie), hit enter, and it still tags Autumn.

Hi @Melanie_Moul, sorry to hear that you are also experiencing this issue. Our developers are currently working on this, but they don’t have updates to share just yet, As soon as I hear back I’ll post the updates here in the Forum!

1 Like