Mauvaise reconnaissance de caractère lors de l'export en csv


#1

Bonjour,

Lors de l’export en fichier csv, les caractère “français” (comme les accents : é, è) ne sont pas reconnus. Par exemple, le “é” est remplacé par “é”, le “ô” est remplacé par “ô”, …

Nous allons faire une petite macro qui corrige cela en un clic, mais comment résoudre ce problème autrement ?

Merci
Bonne journée
Julien


#2

Salut @Julien_RENAUD ! Tu devrais pouvoir régler ce problème en changeant ton encodage en utf8 dans Excel; voici la marche à suivre: https://help.surveygizmo.com/help/encode-an-excel-file-to-utf-8-or-utf-16. N’hésite pas à me faire savoir si tu continue à rencontrer des difficultés. Bonne journée :slight_smile:


#3

Salut @Marie
Je viens de faire la manipulation et malheureusement ça n’a pas fonctionné …
J’ai enregistré en changeant l’encodage, puis chargé à nouveau le csv et c’est toujours pareil.
Mais cela est peut-être dû à Excel, il faut trouver la bonne option à cocher :wink:


#4

Ok, le meilleur moyen de vérifier si le problème vient d’Excel, c’est de tester avec un autre logiciel :slight_smile: Pourrais-tu vérifier si tu peux reproduire le problème avec Google Sheets?


#5

Bonne idée !
Avec Google Sheet pas de problème, donc ça vient d’Excel, je vais faire quelques recherches sur le web.


#6

Ca marche, n’hésite pas à me tenir au courant si tu trouves la solution :slight_smile:


#7

Sorry to reply in English but I open my CSV’s with Libreoffice. Works like a charm. Let me know if that helped as well.


#8

Effectivement en faisant quelques recherches sur le web, j’avais vu que cela fonctionnait très bien avec d’autres logiciels que Excel, mais je me disais qu’il devait y avoir une solution … Merci pour l’astuce @Thomas_Rypens :slight_smile:

Indeed by doing some research on the web, I saw that it worked very well with other software than Excel, but I thought that there had to be a solution … Thanks @Thomas_Rypens for the tip :slight_smile:


#9

Salut @Marie
J’ai enfin trouvé la solution :tada:
Alors il y a effectivement une histoire d’encodage, voilà la solution qui fonctionne:

  1. Charger le fichier csv depuis l’onglet Données et “A partir d’un fichier texte/CSV”

  2. Une fenêtre apparait au chargement du csv

  3. Il est alors possible de sélectionner un type pour “Origine du fichier”, et là en choisissant UTF-8 ça fonctionne :slight_smile:


#10

Bien joué @Julien_RENAUD :clap:t3: et merci de d’avoir partagé la solution avec nous!