Invite by e-mail not working for a specific e-mail address

Hi! I am not able to invite a team colaborator because the invitation e-mail is not reaching his mail box. It is happening with his commercial e-mail account. We tried the his personal e-amil address and it worked, but we need to use the commercial one.
Anyone faced same problem and can help me? Thanks.

Hi @Glaucia_Lima_Medeiro, any chance the invitation is landing in their spams?

Hi Marie. We have already checked the spam box. It is not there.

Sounds like this email may be stuck somewhere.

  • Is your colleague sharing the email domain than you? And if so, are they already a member of your Organisation, you can check this by asking them to click on their profile picture (providing they have an account) and see if your Organisation appears in the list below their picture).

  • Are you trying to invite them to a project, a team, or to your Organisation?

We are not sharing the same domain and we are not part of same Organisation. I am trying to invite him to a project.

Got it! Unfortunately, this looks like this is not something we’ll be able to resolve via the Forum, so I’d recommend reaching out directly to our support team who will be able to take a closer look into this for you! Make sure to share the email address of the person you’re looking to invite as well as the URL of the project you want to invite them to, this will help speeding up investigations!

Many thanks Marie! Could you please send me the link of the support team? I couln’t find it in the site.

1 Like

I see that the link is in your message. Many thanks!

1 Like