I can't find the tasks I want to use as dependencies

Hi Folks, I’m trying to set up dependencies on a project, but for some reason I only get a limited set of tasks and am not able to find the task or sub-task I need, which is the dependency. I tried changing the project from private to shared and also tried adding dates to the depedency taks, but neither worked.

That’s a tough one. I have noticed that Asana sometimes behaves as if it were slowly indexing in the background, and a task may not be searchable for many minutes or even an hour or more after being created. Coud that be it?

Thanks, Stephanie! I think some of these tasks have been in their a while. There are a lot of tasks and only a very small percentage show up in dependencies, so maybe that’s part of it?

Welcome, @Scott_Keiner,

Sometimes it’s easier to first go to the dependent task, click Copy task link (or copy the link from the browser URL field), then when adding the dependency, paste that link instead of trying to autocomplete. Does that find it?



1 Like

Thank you so much, Larry! That worked. I had no idea you could cut and past the link into that window.


1 Like

Stéphanie is 100% correct, indexing sometimes take a long time and you might have to visit the newly created task to get it force indexed. Larry’s trick is what I use often myself.

1 Like

This topic was automatically closed after 6 days. New replies are no longer allowed.