How can I remove custom fields from a project?

I have double checked that I have all fields disabled except “Asignee” and “Due Date” in customize sidebar. I have also ensured I have no Task templates configured. Yet for some reason whenever a new task is created, a bunch of un-wanted fields appear.

Hi @JeffersonEcommerce , welcome to the forum :smiley:

What you describe by ‘disabling’ is actually hiding from the project’s List/Board view - the blue toggle buttons do just that, they hide fields but do not remove the fields from the project, therefore the custom fields still appear in your task details because they still exist in your ‘Project Management’ project.

To remove these custom fields, you will need to go to the ‘Customize’ menu and under Fields, click on the pencil icon next to the name of each of these fields. Then, in the lower left corner of each field’s editor window, you will then have the option to ‘Remove from Project’ (if the field is in the library and used in other projects/portfolios) or ‘Delete field’ (if the field is not in the library or only exists within your project). You can also do this from the action menu of the field’s headers.

(the above assumes that all the tasks in your project are not multi-homed in other projects too, as your screenshot suggests)

PS: I renamed the topic title to be more searchable. The ‘default’ fields usually refer to the 9 fields that include assignee, due date, created by etc that cannot be removed - but they can be hidden from the List/Board view using the blue toggle buttons.

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.