Cannot remove fields within a task

There are custom fields that I cannot delete within a task:

When I hover over the field, there’s no delete button.

I’m the Project Owner, so I don’t think it’s a permission issue.

Any suggestions?

Hi @Christopher_Steen,

Custom field presence/visibility isn’t managed from a task itself; rather, it’s managed via the “Customize” menu on the right-hand side of the project view:

1 Like

Hey Phil,

Thank you for the quick response!

I have all of the custom fields turned off, but the custom fields within the task are still showing.

Yeah, I probably should have given a bit more info.

The toggle switch is just used to show or hide a custom field as a column in the project list view. To actually remove the field itself. you have to hover over a field in that list, click the pencil icon to get to the Edit Field dialog - there you can actually delete the field (or simply remove it from the project if it’s an organizational custom field in your custom field library - that’s a whole other topic, let me know if you don’t know about project-specific custom fields vs. organizational fields…)


That did it! Thank you so much!


This topic was automatically closed after 3 days. New replies are no longer allowed.