Harvest unable to log in inside Asana

This morning when I tried to start tracking time on a task, Harvest was unable to log in. I’m in Firefox.

I click on the clock icon to start tracking time.

Harvest modal is displayed, and I click to Sign in.

I’m able to select my company.

But after clicking, the modal closes, and Harvest is still logged out, making it impossible to start tracking time.

1 Like

Welcome, @Melissa_Fernandes, and sorry to hear this.

I think you might have to contact Harvest support directly.

Though if you prefer, you could start with support@asana.com (it might take longer if in fact Harvest support is required).



I have exactly the same problem. I suspect it appreared after update of Firefox. Melissa - have you found any solution?

I’m having the same problem. Works in Chrome (which I don’t really use) and not in Firefox. Keep on getting the note that I have to be logged into Harvest even though I AM logged into Harvest, in the same browser.

I had to download Asana for Windows to be able to track time, but unfortunately, it doesn’t display the total time spent on a task. I contacted Asana support and I’m not sure if they will work on a fix since they said to use Chrome.

Having the same issue. Hope there is a solution soon. Same in Trello for what it’s worth, so this might be more of a Harvest issue than Asana.

Briefly describe (1-2 sentences) the Bug you’re experiencing: Since 2 weeks ago, I have been having problems with the sync between ASANA and HARVEST. Every time I click on the clock on a task, it asks me to login. Problem is. I already have logged in tons of times and this screen of login keeps asking again and again. ( Never advances or cycles).

I already cleared cache, cookies, etc… And still the same behaviour.

Steps to reproduce: Click no Task, click on the clock to start counting time for the specified task. Instead of being served the task info and time, it just asks me to login. Upon login to Harvest, the screen goes back to Login.

Browser version: Firefox 109.0

Upload screenshots below:

Hi @Cesar_Rodriguez_ADMI and thanks for the report. We head this from other customers too and our team is looking into it. I’ll keep you posted here once I have an update!

This seems to be related to the Firefox Enhanced Tracking Protection. I was having the same issue and disabled it for my Asana portal and then it worked as expected.

You can disable it in Firefox by clicking on the shield icon to the left of the address bar.