Full screen mode does NOT utilize the full screen

When I want to see the comments in a task and I chose “Full Screen” mode from the menu, I really want to utilize the whole screen NOT just approximately half of it (I have a large display).

The reason that this is helpful, is that often we may paste looong lines in the comment (eg from system-log files) and those are much better seen if the full width of the screen is used so the lines do not wrap.

Thanks

I also feel this way. My expectation would be that the interface would be responsive to accommodate larger screens.

3 Likes

Surely a responsive interface is not too difficult to implement. It would make the UX infinitely better with very little effort. I’m disappointed that this hasn’t been done already, and concerned that this is an indicator of the lack of progress being made to improve the software.

2 Likes

Old topic, but still unfixed. As a developer with 2560 pix screen it is quite annoying that the full screen mode is fixed at 900 pixels, i.e. utilizing just center 33% of the screen. Even worse on 4K monitors.

However if you are technically inclined (or have a friendly frontend developer sitting nearbly) there is a hack you can use with Chrome:

  1. Open Asana in Full Screen view
  2. Select “Tools” → “Developer Tools” from the “Chrome” menu (or right-click anywhere on page and select “Inspect”
  3. Select “Sources” → “Overrides” → “Enable local overrides”
  4. Chrome asks for a folder where to save the override, you can choose any folder. Then a banner should appear on top of chrome asking for permission to save to this location.
  5. Select “Elements” and scroll down to “<div class=Pane FocusModePage-taskPane”>", at same time you should see the task card highlighted
  6. On bottom right of screen you should see “Styles”, and in there
    .FocusModePage-taskPane {
    -webkit-box-flex: 0;
    flex: 0 1 900px;
  7. Change that 900 value to 1500 or whatever looks nice on your screen

The change should persist across sessions, and if not just go back to Developer Tools → Sources → click again on “Enabe local overrides”.

There are also Chrome Plugins like Stylebot that should be able to achieve the same.

1 Like

thanks for the interesting solution. Unfortunately I want to stick with firefox for now. :slight_smile: Is there a similar solution for firefox that anybody knows? (I can google obviously, so I might do that at a later stage and reply back if so)