Followers property on project creation not working anymore

Hi,

we integrated Asana in our Project Planning System and it worked perfectly for about 6 months. Suddenly it stopped working with the Error “403 Forbidden”. After a small research session, I found out, that this happens only if the “followers” property is present when creating a new project. The team didn’t change, its still the same. I’m not sure what happened here.

asanaClient.projects.create(project)
          .then((projectRes) => resolve(projectRes))
          .catch((err: any) => {
            console.log(err);
            reject(err);
          })

project object:

>  {
>    name: 'Testproject1',
>    owner: 'my@email.com',
>    html_notes: 'Lorem ipsum dolor sit amet, consectetur adipiscing elit. In elementum.',
>    start_on: 2021-06-01T00:00:00.000Z,
>    due_on: 2021-07-01T00:00:00.000Z,
>    public: false,
>    color: 'dark-red',
>    followers: 'my@email.com,employee1@email.com',
>    team: '720838787747337'
>  }

After deleting

>    followers: 'my@email.com,employee1@email.com',

everything works fine.

Can anyone pls confirm this error? Thanks in advance!

Follower represents a user object; I’ve always used gids for that property. I guess I’m a little surprised you’re saying it previously worked to use email addresses, but I would try using user gids instead and see if that works.

1 Like