Due Dates and Times malfunctioning in Saved Search

In a Saved Search sorted by Due Date, when I give a “Due Time” to a task, it does not sort on the correct date/order chronologically.

Steps to reproduce:
Save a search that includes tasks. Sort it by due date. Select a task with a due date and add a due time. It slides in incorrectly.

Browser version:
Chrome Version 97.0.4692.99 (Official Build) (64-bit)

Upload screenshots below:

Hi @Andrew_Seidman and thanks for the report. Could you share the criteria you have used in your Search to help us investigate this issue?

Yep, please see attached image

Thanks for the reply @Andrew_Seidman!

I’ve filed a bug for our team to investigate, I’ll keep you posted as soon as I have an update!

@Andrew_Seidman our team has some follow-up questions:

  1. Does that incorrect sort persist even after you refresh the page?
  2. Does that incorrect sort persist after you switch to sorting by another field and then back to sorting by due date?
  3. When you say “Sort it by due date. Select a task with a due date and add a due time. It slides in incorrectly” are you setting a due time on a “tomorrow” task to be “Tomorrow 8:00 pm,” and then Asana automatically moves it to the bottom of the list?

Thanks for your help! :pray:t3:

  1. Does that incorrect sort persist even after you refresh the page? - ANDREW: Yes
  2. Does that incorrect sort persist after you switch to sorting by another field and then back to sorting by due date? ANDREW: Yes
  3. When you say “Sort it by due date. Select a task with a due date and add a due time. It slides in incorrectly” are you setting a due time on a “tomorrow” task to be “Tomorrow 8:00 pm,” and then Asana automatically moves it to the bottom of the list? ANDREW: I set a due time on a “Tomorrow” task and then Asana moves it to the bottom of the list for the next day.

For what it’s worth its almost certainly a “time zone” related bug. I am on Pacific Time. If I set a “Due time” as 3:59pm, it stays in the correct order. If i set it to 4pm, it moves it to the bottom of the following day. So, when I am setting it to “4pm” it thinks I am setting it to 12am for the following day, and gets confused.

bump!

bump again

bump for @Marie

Sorry for missing your last messages @Andrew_Seidman. I’ve followed up with our engineering team and will be in touch here as soon as I have an update!

greatly appreciate it @Marie ! would love for my tasks to all order properly :slight_smile: thanks much

@Marie bumping this one along again. I’m 99% sure this is a timezone fix that should be simple?

bump bump bump, bumpity bump bump bump bump ba-dah (sung to the tune of rapper’s delight) cc: @Marie

Hi @Andrew_Seidman and sincere apologies for missing your last messages. I have pinged again the task I filed for this bug and will make sure to have an update for you asap!

Much appreciated, thanks @Marie !

@Andrew_Seidman, just an update to let you know our team is actively looking into this. I’ll keep you posted here once we come to a resolution!

very excited to hear any updates in the last month! thanks @Marie :slight_smile:

1 Like

I’ve just commented on the task I filed and will keep you posted here once I get an update. Thank you so much for your patience @Andrew_Seidman !

thanks so much @marie! I run my entire life and my business based on Asana so fixing this will really help me a lot :slight_smile:

1 Like

Howdy @Marie any update on that comment on the task you filed? thanks!