Custom fields not showing in Board view at Task Level


I don;t see custom field from project level replicated at Task level when in BOARD view

however I can see it in the List view

what am I doing wrong?

also how can I customize the order of fields?

thank you in advance

Hi @Andreea_Simion, welcome to the Asana Community Forum! Let’s try to solve this together!

Could you confirm if the custom fields are toggled on when you access the Customize option? For example:

From that list, you can also drag and drop the fields to organize your columns in List view.

Looking forward to your reply!