Custom Fields + Library Disappeared from Form

Spent months creating a form with custom fields which were added to my org’s library. Reviewed the form and functionality with my manager. Several hours later when he tried to present to his manager, all the questions that used library custom fields were gone. I tried to select them again but the “thinking circle” kept spinning.

I’ve also submitted an IT ticket within my org.

Hi @anon96449303 , sorry to hear about this, it’s indeed strange!

Have you tried refreshing your browser or tried opening Asana in a private/incognito window?

Also you may want to try adding one of these custom fields from your form to the project that your form is in, from the List view or from the Customize menu under Fields> Add field.

Do you still have the same issue of the custom field library not producing any search results and stuck on loading?

You may also want to ask around within your org in case someone went through your custom field library and perhaps deleted some fields by accident…? That’s what the red text in the form questions tells me… :grimacing:

1 Like

@Richard_Sather - Thank you for those suggestions.

The project which houses the form is nothing more than a vehicle to hold the form. The form is a project /registration intake. Once submitted, rules auto convert the “task” created by the form into a project using a project template. That auto-converted project is then auto added to two portfolios: 1) my team uses for governance and 2) the portfolio of the team that owns the project. All those custom fields were then added to the portfolios in order for us to perform governance and reporting. So this is a big deal that the custom fields are suddenly not able to be added to the form - it disables the entire intake and governing process.

As a test, I was able to add a few of the custom fields from the library to the project which holds the form. So, the custom fields are still in the library. When I click to connect to a field, then click to select from library, it still just spins and never populates the view (as in the first screen shot above). So, I’m not able to access the library fields in the form.

Incognito browser - I closed the current browser, reopened browser and selected private. Then clicked launched the Asana app again. No difference. Also tried logging in via in the private window but looks like my company did not allow that.

Fixed: The custom fields were removed from the project. After I added the fields back to the project, the form auto pulled them back in. Thanks again for helping me figure that out.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.