Custom field does not show up in the rules

Important note: To help us resolve your issue as quickly as possible, please ensure to fill out all the sections below. Do not share any private information such as email addresses or phone numbers - This is a public Forum!


Briefly describe (1-2 sentences) the Bug you’re experiencing:

The custom field is not showing up in the rule set

Steps to reproduce:

Create a custom field, make sure it is added to the project, and open the ruleset

Browser version:


Version 1.61.120 Chromium: 120.0.6099.234 (Official Build) (arm64)

What version of Asana are you using (Basic/Premium/Business/Enterprise)?

Business

Upload screenshots below:


According to this, only Multi-Select, Text and Numeric custom fields can be used in Rules: Rules set Custom Fields with Text or Numbers - #24 by Marie

This doesn’t seem to correspond with what I find empirically, which is this (green check means I find it available in Rules, red X means not available):

IOW, Dates and Multi-Select Custom Fields ARE available, whereas Text, Numeric and Formula are NOT. :confused:

As I seem to be saying a lot lately, I believe Flowsana may have the capability you’re looking for. @Phil_Seeman

The custom field is defined as a number so theoretically, it should work:

@Marie Any idea why?

Hi @Jasper_Kooij,

First, to clear up one thing, the forum post referenced above (Rules set Custom Fields with Text or Numbers - #24 by Marie ) is referring to rule actions, not rule triggers, so it doesn’t have any relevance to your question here.

While Asana supports setting a value on a number custom field as a rule action, it doesn’t currently support using a number custom field in a rule trigger.

As @Stephanie_Oberg1 notes, our Flowsana integration does support number custom fields in its rule triggers, so that’s a possible solution for you.

2 Likes

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.