CSV Importer: Allow to map out tasks descriptions

tasks
csvimport

#1

I am trying to test out the templates I have created for my training course students so it is easier for my them to import into Asana using the CSV importer tool. Asana Academy training videos and sample templates do this beautifully.

However, when I use the CSV importer, I am noticing that unnecessary data clutter ends up duplicated in the task description field. I was redirected by the Asana support team to this forum so I am hoping someone has a way of fixing the below problems.

There is no option to map the Notes Column from CSV to the description field in Asana. Asana doesn’t have the description field as a drop-down map option, which makes no sense.

Also, the tasks names from a CSV and the blank columns header are replicated in the description field of Asana if the “include data in task descriptions” option is checked instead of the Notes column from the CSV. How do I fix this so only the notes column information shows up in the Asana description field without all of the other unnecessary clutter data? Choosing map to none does absolutely nothing.

Thanks all!


CSV Import Description
#2

Hi @UfuomaO and welcome to the Comunity Forum! You can remove this data from the task description field by unchecking “Include data in task descriptions” before importing your CSV document (See screenshot below).

Hope this helps!


#3

Thanks Marie!

I have tried that option but it doesn’t address my concern about getting the notes I have created to show up in the exact clean way from the CSV into the Asana description field.

Asana support mentioned that the below and I am trying to figure out how they are able to add the task descriptions from CSV into the task description field without all of the duplicate task names and headers also getting added the task description field.

""If you wish to then import the CSV simply map this back out, as needed. Note that the Task descriptions if not applied to any field, will appear in the Task description."
Will the importer work without having headers in the CSV?

~ Ufuoma


#4

Got it @UfuomaO!

Yes, you’re right, as it stands there in no “Description” option in the drop-down used to map out your columns, so the only way to have your notes in the description is to check “Include data in task descriptions” and then manually remove information that isn’t relevant. I understand this is not ideal, bit our CSV importer is pretty new, and hopefully this is something we can improve in the future.

I’ve gone ahead and moved your thread to the #productfeedback category to all you and other Forum members to vote for this feature request. Apologies I can’t be of a greater help here; if you have any follow-up questions, please let me know!


#5

This is a much needed feature. Does not seem that complicated to be able to add a field in the import tool that would match descriptions in a CSV to the task description field.