CSV Import custom field not recognized as organization library

CSV Import will import a custom field with the same name as organization library entry but does not recognize it as custom library field.

A workaround is to add the library field after import, duplicate the data, and then remove the field. The new column then allows the team member capacity to be used in the Portfolio Workload view.

This workaround is unacceptable for importing large numbers of legacy projects into Asana. Asana must be enhanced to add this functionality.

I did it yesterday successfully but I had to choose “Make changes” before importing to map the column to the custom field (it has to be added to the project prior). Does that help?

1 Like

No, that does not work for me. Sequence is as follows:
image

image

image

No option appears to change the column from a Number Field to Estimated Hours.

I think that’s because you are creating a project from an import. You need to create an empty project, add your field from the library and then import the CSV. Only then the field will show up! Does it make sense?

2 Likes

That works! Thank you for the workable sequence. This will help with adoption of Asana in our organization.

My pleasure :slight_smile: the CSV importer is hard to use.

Hey @LEGGO see, I am becoming a CSV import wizard as well!

1 Like

No surprise, @Bastien_Siebman! You’re the :goat:

2 Likes

This topic was automatically closed after 6 days. New replies are no longer allowed.