CSV Category Options Not Available

CSV upload won’t let me assign columns. Is only giving one or two options.

Browser version:
Chrome Version 77.0.3865.90

@Megan_Bailey for the time being you have to add the Custom Fields to your project prior to importing if you want to map specific Columns to known Custom Fields. There isn’t currently an ability to select or search for a known Custom Field within this dropdown.

1 Like

Thanks for jumping in @Jerod_Hillard :slight_smile:

1 Like

Hi Jerod,

I did that, and it’s still not recognizing my categories.

1 Like

AH! It looks like in this case you are looking at the “Subtask of” column. My guess is it isn’t mapping properly because values listed in this column don’t match the name of the desired Parent Task?

Are you able to help me with this? Even though all of the options are pulling up, I can only click one of them (Task Description).

1 Like

We are having the same problem.

1 Like

Hi @Megan_Bailey, from what i see in your first screenshot, it looks like all options in the drop-down menu are already mapped into other columns, which explains why you can’t click on them. Could you please tell us exactly which column you’re looking to edit and what field you’d like to map with this column?

Can you also share the URL of your project?

Looking forward to your reply.

@Guilherme_Puga please create a new thread in #tipsandtricks and share more details about your specific case so we can better advise.

Have both a great weekend!

1 Like

Even though it is showing all options in the drop down menu, I am not able to click on them and they are not mapped out on other columns, I just called my columns the same thing hoping it would match up but they wont. You can tell by the widget image that they’re all linking as “Task Description”. and when I try to upload the project hoping it will just work out, it doesn’t. I would like to map Assignee to the Assignee column, etc.

https://app.asana.com/0/1144482980559566/list

Thanks for your reply @Megan_Bailey,

I don’t think this is a bug but there is definitely a little bit of confusion here :see_no_evil: the new CSV importer automatically maps field out for you (see https://asana.com/guide/help/api/csv-importer). On your screenshot, I can see that our system as automatically mapped all your CSV field for you (ex: “Assignee” is mapped to the column containing the list of Assignee email addresses), so at this stage, unless you think one column isn’t mapped correctly, you shouldn’t have to make any modification.

  1. Could you please confirm which column of your CSV you wish to remap, and what you want to remap it to?

  2. Have you tried to generate your project, and if so, is there anything not mapped out correctly?

1 Like

The issue is that the new CSV importer is not automatically mapping my fields out. When I trust it and send the CSV through, nothing links up and it comes up with empty and unassigned tasks. I’ve changed the headings for my columns so that you can see this. It’s not allowing me to click “assignee for any field”. I also am not able to assign “due date”.

I have tried generating my profect multiple times and nothing maps out accurately.