CSV Import - Custom Field Mapping

I’m running into an issue with the new import UI where it will show the correct value of a Custom Field within the preview but once the import begins it maps the field to the drop-down selection that is one after the correct selection. In this instance I am mapping data to a Custom Field called “Contract Year”. In the image below you can see the value of that field is previewing as “Year 8” which is correct. However, when imported the value shows to be “Year 9” as shown below.

Preview:

Result:

I attempted this twice and got the same results. I am also finding that the pop-up in the bottom left never completes once all the tasks have been imported.

No Pop-up Updates:

Browser version: Google Chrome is up to date - Version 76.0.3809.132 (Official Build) (64-bit)

Thanks for the report @Jerod_Hillard,

Would you mind sharing your CSV file and the URL of your Test project by DM to help me investigate this further?

Looking forward to your reply! :slight_smile:

Hi @Jerod_Hillard and thanks for your patience! I just tried to reproduce the issue with the CSV file you DMed me, and the data I’m seeing in the test project I created for the occasion is correct (see screenshot below), so I’m not sure what’s happening there! I’ve gone ahead and filed a bug with our Product team to investigate this further and I’ll keep you posted as soon as I have an update!

@Jerod_Hillard, so our team just came back to me, and something caught up their attention. On you screenshots, the “Contract Year” custom field has no field option color, which doesn’t match the preview. In order to continue investigating, could you answer these few questions?

  1. Is this a dropdown custom field?
  2. If so, what field options have you set up?
  3. Are you creating a new custom field for Contract Year or using an existing organizational one?
  4. Any chance you have modified the options for the custom field after importing?

Looking forward to your reply!

@Marie thanks for responding. I just got a chance to try this again and got the same result. I wasn’t able to see a screenshot in your previous reply however.

AH! Nice catch by the team (noticing the lack of colors)

To answer your questions:

  1. Yes
  2. The field options are 2010-2030 and Year 2-25 for a total of 45 individual options. See screenshot below. Perhaps that is the issue and I have too many options for a Custom Field?!?

  1. Existing organization one (the best way :wink: )
  2. No modifications. I thought perhaps that was the issue too, as if the Field option or the CSV cell had a space in reference name. Doesn’t appear to the be the case either. :frowning:
1 Like

Thanks for the quick reply @Jerod_Hillard, we’re :male_detective:‍♂into it and I’ll make sure to keep you in the loop as soon as I have an update :slight_smile:

1 Like

@Jerod_Hillard,

So sorry for the trouble, but would you be able to forward us a screencast by any chance?

Loom is a great app for video screencasts: https://www.useloom.com/

In your video screencast, we recommend that you use a Chrome Incognito window and have your Javascript console open:

** https://support.google.com/chrome/answer/95464?hl=en*

** https://developers.google.com/chrome-developer-tools/docs/console#opening_the_console*

Try to include the entire browser window, including URL bar, in the video screencast.

Also, is this consistently happening? Could you also check if you’re able to reproduce with another project?

THANK YOU so much for your help and patience with this!

1 Like

@Marie

I hope this gets you what you need. I ran another test with a different field option and it did the same thing - selected the “next” option instead of the one identified, e.g. selecting 2010 instead of 2019 and Year 9 instead of Year 8.

1 Like

Cheers @Jerod_Hillard, really appreciate it.

I’ve removed the screencast from the thread to preserve your info, but I’ve forwarded it to our team! I’ll keep you posted as soon as I hear from them!

1 Like

@Marie, for that it is worth, if I don’t browse in the Organizational Custom Field prior to importing (thus it creates a new Custom Field with only 1 field option) then it DOES NOT list the Contract Year as “Year 9”. I do believe this behavior has something to do with the number of Custom Field options - causing an unexpected offset when importing the data. :wink:

1 Like