Copy/Paste list to create task/subtasks in batches is not working

If you pasted a copied text list in the subtasks area, it would create a single subtask per line. But since today, it creates ONE subtask, with a title that has linebreaks in it.

Steps to reproduce: In a Task, press Tab+S and paste this list:

task one
task two
task three
task four
task five

Browser version: Latest Chrome/Firefox/Edge on Windows 10



That will break a lot of people workflows :scream:

Thanks for the report @Raphael_Bergmann.

I’m able to reproduce this issue but it is quite inconsistent (I’ve also been able to create multiple subtasks by pasting a list); so I’ve gone ahead and filed a bug for our team to look into it!

I’ll keep you posted here as soon as I have an update!


Briefly describe (1-2 sentences) the Bug you’re experiencing:
Subtasks - pasting a multi-line list now creates a SINGLE task instead of creating multiple sub-tasks.

Steps to reproduce:
1.) open text file and type in 3 lines:

2.) copy those 3 line to clip board
3.) Inside a project click “Add Task”
4.) Inside Task either CTRL-S or click icon to create subtask
5.) CTRL-V
6.) This will now create 1 subtask named:

Instead of creating 3 separate subtasks.

Browser version: Chrome 75, Internet Explorer 11, Firefox 68

Upload screenshots below:

I normally get a list of tasks I have to perform on a particular phase of my project sent to me from the field inspectors. Up until this morning, I would simply copy the list from their emails and paste them into the subtaks and get a series of multiple subtasks. This is essential to my work flow, to have a block of items now as ONE task is completely useless. And to now have to MANUALLY type in EACH line SEPARATELY is daunting. I get receive multiple lists throughout the day which need to be added to various tasks among various projects.

Copy and Paste has worked for the last 18 months up until this morning.


Updated Price and TAx
Page 2
Ridge CAp
Syntetic Felt
Insulation TYVEK All House
Siding Not Available See Hover
D/R 1 ATAT Box
R/R 3 WRaps Not 2
Left Elevation
D/R 1 Light
D/R 1 Electric MAst
D/R 2 Electric Outlets
BAck If Siding Not Exist
D/R 1 Light
R/R 5 Windows Wraps
TYvek / Insulation
1 Dryer Vent
1 Electric
Final Cleaning

Hi @Robert_Frisby :wave:t3:Thanks for the report and so sorry for the trouble here! We’re aware of this bug and our dev team is investigating it as we speak! We already have a thread for this bug in the Forum, so I’ve gone ahead and merged your post with this existing thread so you can follow along updates! I’ll update the thread as soon as we have a resolution on the way, thanks for your patience!

Note to everyone following this thread :wave:t3: I’ve slightly edited the title to make this thread more discoverable to other users looking to report the issue; hope you don’t mind!


I’ve started using the free version of Asana as my organization is small (< 8 employees) and want to see if it is a workable solution before upgrading.

My question is yesterday I was copying & pasting tasks and subtasks from another document in a list format and it was pasting as individual tasks or subtasks which was ideal. Today I’m doing the identical process and Asana is pasting the list into just one task/subtask. How can I get this to how it was originally functioning.

Hi @Todd_Gurule and welcome to the Asana Community Forum :wave:t3:

We’re currently experiencing a little bug preventing you from pasting lists in your project to automatically create set of lists! Our team is currently looking into it! Moving your post to the existing thread we already have in the Forum so you get notified as soon as we post an update!

Oh! So great to hear! This has been a real bummer so far and I wan’t sure what to expect as far as response. Your prompt communication has been very reassuring. Thank you!

1 Like

We have a fix in beta which should be live in the next couple of hours and solve this issue for everyone. I’ll make sure to post in this thread as soon as it is the case!


The fix is now live for all our customers, so this bug should be resolved!

Marking this thread solved, but please let us know if you continue running into trouble. And thanks again for your patience while we worked on resolving this issue!


I’m sure I was able to take a list from google docs, sheets or notes and paste into Asana where a page break would mark the start of a new task and now everything is being pasted in the same task. Is there a workaround for this? We use docs when a project hasn’t been prioritized since it has all the research details, and all the activities are in lists in these docs, so it is incredibly annoying to have to paste them one by one.

I think this is a known bug from a few days ago. @Marie will merge it for you!

Thanks @Bastien_Siebman and thanks for the report @Maria_Luisa_Rhodes!

This bug should now be resolved. I’ve gone ahead and merged your post with the existing thread we had on this topic. Feel free to reach out if you continue running into trouble!