Cannot print a project

Briefly describe (1-2 sentences) the Bug you’re experiencing: When attempting to print a project (sorted by custom field) the command continuously spins with no resolution.

Steps to reproduce: Project Actions, Export/Print, Print

Browser version: Chrome, Firefox, Explorer

Upload screenshots below:

Hi @Angel_Clark and thanks for reaching out. Sorry for the trouble there, let’s see if we can solve this together.

From what I can see in your screenshot, it looks like you’re having connecting issues, which explains why the page isn’t loading.

Can you give a try to the troubleshooting steps in the article and let me know if the issue persists?

OK. I tried all of the tips in the article and the issue persists. If I turn off the sort by [custom field], the issue is resolved; however, I really need to be able to print the view that sorts by my custom field.

@Angel_Clark I replicated your trouble report. If one attempts to print a project that is sorted by a custom field, one will see an endless “Printing…” screen complete with swirling icon. I’m up to 2 minutes now, and counting… UPDATE: Then an Asana crash and warning about copying text to avoid data loss. Meanwhile, I have another browser window with Asana, and numerous other tabs and apps, all working fine and showing no connection issue.

Where if the project is NOT sorted by a custom field, the Print Preview pops up within less than 1 second. So @Marie, this is NOT a connectivity issue…at least not the ordinary kind. It appears to be a bug. Would you mind printing a project with a custom field, sorted on that field, and see how it goes, please?

1 Like

Thank you both for your input! I’ve managed to reproduce the issue on my end to and have filed a bug for our team to investigate.

In the meantime, I might have a workaround for you @Angel_Clark. If you run an Advanced Search for all task in your projects, and sort your search results, you should be able to print. I’ve just checked on my end and it seems to work for me, so hopefully it can help you while we work on a resolution.

I’ll keep you in touch as soon as I have an update on my end!

Thanks Marie, I appreciate the responsiveness.

However, I don’t see how the workaround can work. Advanced Search results CAN be sorted, but not by custom field, at least for my service tier of Premium. I guess I could output them to Excel or similar, and then sort that; is that what you meant?

Thanks for looking into this, Marie! I tried the workaround - but still not able to sort by my custom field, so no real help there, but I look forward to hearing back on any resolution on the root issue. Thanks! Angel

Hi folks,

Our team has pushed a fix for this and I can’t seem to be able to reproduce anymore on my end, so I’m marking this bug resolved, but please don’t hesitate to reach out it you’re still experiencing some issues. Thanks again for taking the time to raise this issue!

Yup, showing as fixed for me. Thanks for the fast response Marie!

Same! Appears to now be working on my end. Thank you, Marie!

1 Like