Attachment disabled for comment-only collaborators

Briefly describe (1-2 sentences) the Bug you’re experiencing: Comment-only users cannot attach files in their tasks. The button has dissapeared

Steps to reproduce: Set a task to a user as comment-only and try to attach any file

Browser version: Chrome and desktop app

What version of Asana are you using (Basic/Premium/Business/Enterprise)? Business

Hi @Manel_RodríguezC , thanks for your post and I’m sorry to hear you run into trouble here!

Please note that it is expected behaviour to not see the attachment button in the comment box when you first click on a task:

However, if you click on the comment box itself you will then be able to see the attachment button as per the screenshot below:

Can you please confirm if you’re able to see it on your end by following the instructions below?

If not please ping me on this thread and I’d be happy to escalate your issue further.

Thanks :slight_smile:

Hi @Ainhoa_Rico, my question is not regarding comments but tasks.
Until friday users had a clip button to attach files without needing to comment. Located in the top bar options of the task.

Now we are using the comments to upload the files as you mentioned. Maybe is expected to be this way, but it is strange because edit users can do it but comment-only can’t.


Same issue as well also now not being able to edit my comments in comment only tasks

1 Like

Hi folks,

Thanks for flagging this, I have now escalated this to our Development Team so they can have a look at it and will circle back once they provide me with an update, thanks!