Cannot attach a file in comment on Chrome

Briefly describe (1-2 sentences) the Bug you’re experiencing:
Cannot attach a file in comments on Chrome

Steps to reproduce:

  1. Open a task or a conversation
  2. Click the comment field
  3. Click the file attachment icon
  4. Choose “Your Computer”
  5. Select a file
  6. The dialog closes without the file being selected. No error logged in JavaScript console.

Attachment to task (not tied to comments) still works, with with drag-and-drop, with copy-paste, and by clicking the icon.

Browser version:

Not working:

  • Chrome Version 111.0.5563.146 (Official Build) (x86_64) on Mac
  • My colleague has the same issue with Chrome on Windows
  • EDIT: In the replies, I heard that the desktop app has the issue too


  • Firefox
  • Safari

What version of Asana are you using (Basic/Premium/Business/Enterprise)?

  • Basic, Premium, and Enterprise

Upload screenshots below:

File attachment issue


I am currently having an issue with attaching files, I use Asana website.
But no issue when dragging the files into the task. Can anyone help me?

1 Like

Hi @Yuly_Ekadewi and thanks for your question.

Based on the information you provided, I will merge your request to a recent similar article in the BUG category.

If your issue is different, please let me know and try to provide as much information as possible (“Steps to reproduce”, “Browser version”, “Screenshot”).

Cheers :wink:

1 Like

Hi @ShunS Thank you for reporting this issue. The product team is investigating this issue. I will circle back here if there is any update.


Hi @ShunS thank you for reaching out.
Yes, I’m facing the exact problem that’s shown in the video above. I have no problem with drag-and-drop attachment, but I’m more comfortable with attaching from comment box. Can you tell me what I have to do?

1 Like

Hi @Nao_Kumazaki Thank you for your help. I am looking forward to any update so I can attach files from comment box again.

1 Like

Having the same issue. Can’t attach file from the ASANA desktop app. Only can attach by drag and drop and copy-paste.

1 Like

I’m having the same issue. I’m using the Asana desktop app in iOS. I’ve tried resetting my computer and the app but to no avail.

1 Like

SOS! :sob:
Having the same issue. I can’t attach file in comment from my computer

Facing the same issue (using Asana web version, google chrome)


Hello, I have same problem when attach file, nothing happened. It cause a lot of troubles for us. Kindly help me to fix it.

1 Like

I am also having the same issue. When I attach a file, nothing happened after that.

1 Like

I’m having the same problem. nothing happens when i try to attach a file

1 Like

Hi all, sorry for the inconvenience.
Could you please use the Attachment icon on the top-right menu? :slight_smile:

Hi! I and my team also have this problem since morning

1 Like

Hi , we face the same issue since this morning ! we could add the attachments fine earlier on

1 Like

Hi, same problem with our team today. Using for now different ways to attach files.

1 Like

Attaching a file via the top-right menu works, same as dragging an attachment just into the task.

The main thing that does not work on my end is attaching the file into a comment via the bottom attachment icon


Hi our company is experiencing the same issue. Cannot attach file from asana comment.

Hi! Our company is also having issues with this. We tried using Chrome and Firefox.