Asana Desktop App not appearing in MacOS' Notification Center

Important note: To help us resolve your issue as quickly as possible, please ensure to fill out all the sections below. Do not share any private information such as email addresses or phone numbers - This is a public Forum!

Briefly describe (1-2 sentences) the Bug you’re experiencing: The Asana Desktop App in MacOS does not allow me to adjust notifications so I always have Badge App Icons. I tried installing and reinstalling the Desktop App and that does not fix the issue.

Steps to reproduce:

Browser version: No browser. But my MacOS is current at 13.3.

What version of Asana are you using (Basic/Premium/Business/Enterprise)?

Upload screenshots below:

1 Like

Hi @JohnAbeel and thanks for your question :raised_hand:

I use Windows, then maybe my suggestion is off-topic, but have you tried configuring the notification in the app (My settings > Notifications > Desktop notifications)

Let me know :wink:

In addition to Arthur suggestion, in the Mac OS settings you showed you can definitely allow or disallow the badge. What are you trying to do exactly?

The Asana desktop application is not showing up in Settings > Notifications. You may not have noticed on my screenshot, the Notifications list is in alphabetical order, and the Asana application is not there. Because it’s not showing there, I cannot disallow the badge.

Thanks, Arthur. Yes I have tried but the Appsettings do not contain an option to control the Badges that MacOs places on the App icons.

wow indeed :scream: shows up on my computer :sweat_smile:

Looks like it’s an issue for some based on the previous post in my screenshot :man_shrugging:. I’m hoping Asana has an answer.

Hi everyone, thanks for reporting this! According to our team, this is a MacOS related issue, where apps don’t appear in the Notification center, preventing users from changing the notification settings for apps.

The steps below seem to resolve the issue for most users reporting it:

  • As there are multiple places where these notifications can be enabled or disabled, I would like to start within the Asana app itself. Within your profile, and the My Settings, there is a Notifications tab where you can enable the desktop notifications for various actions within Asana. Could you please check if you have checked all relevant boxes?

  • If after adjusting your desktop notifications in the Asana Desktop app does not force your Notifications center from listing Asana as an app to edit, please uninstall and reinstall the app. After you log in, review your desktop notifications settings within the app again, and then proceed to the Notifications center to see if Asana is listed.

Another user resolved the issue by doing the following:

  1. They went into Notifications tab and just switched on the Desktop notification (they did that to trigger the Notification Center)
  2. Then they uninstalled the Asana app and re-installed it.
  3. Then, they got a little notification banner on the right side corner near the clock
  4. They left with the option to “Allow”
  5. After these actions they could find Asana under the Notification Center in their Mac.

I understand that this process is a bit inconvenient, but since it’s a MacOS related issue, we can only provide limited support here. If the problem continues after troubleshooting with the steps provided, we recommend you reach out to Apple Support for further assistance.

I hope this helps! I’m closing the topic since this is not an Asana bug, but let me know if this worked for you.

Thanks!. I’ll give these a try.

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.