Ability to drag and drop tasks in the new sidebar

Important note: To help us resolve your issue as quickly as possible, please ensure to fill out all the sections below. Do not share any private information such as email addresses or phone numbers - This is a public Forum!

Briefly describe (1-2 sentences) the Bug you’re experiencing: cannot drag and drop tasks in the app or web browser

Steps to reproduce:

Browser version: Chrome Version 111.0.5563.147 / Edge Version 111.0.1661.62

What version of Asana are you using (Basic/Premium/Business/Enterprise)? Business

Upload screenshots below:

** have tried updating browser -


Hi @Dan_Shone and welcome on the forum :raised_hand:

Would you please upload a screenshot to see if there is anything that could explain that behavior.

For example, if a sorting option is applied (ex, the due date); it is expected that you can’t move a task inside a section (as the sorting prevails, and prevents a manual ordering).

Also, are you trying to drag and drop within a section, or between sections? (or both)

Thanks :wink:

@Dan_Shone, is this for one specific project or all?
You might be in a project that you have comment-only access…?

Please provide a bit more information so that we can help you :wink:

there are no sorting options applied and it’s for all users. what we could do until recently is drag a task from one project to another.
screenshot attached.

what we could do was drag one of the tasks in our factory productiion queue to our completed project. please excuse the green mark, but we have fiarly tight NDA’s for most of the work that we do.

it’s all projects, not just one. re the access permissions, it’s the same for me as well and I’m the super admin.

HI Dan,

Has this only happened since the new UI interface?

its only been for the last 3-4 days. not sure whenthe UI update was.

Just tested on the new UI - seems this funtion doesn’t work anymore

Hi @Danielle-GenD , I just tried it and it works, but only when you drag tasks into a project within the Starred section (not the Projects section), it will move the task there.

However, when hovering the mouse over, it shows a blue hairline above/below the project, instead of highlighting it as one would expect.

I’m wondering if this is an A/B test… @Marie ?


Hi everyone, thanks for flagging this. I’ve escalated this to our Developers to confirm if it has something to do with the new design. As soon as I have any updates I’ll get back to you!


Hi folks, thanks for your patience! Our team has confirmed that this is not a bug, but expected in the new layout. That said, they are taking note of every piece of feedback regarding the new sidebar to keep in mind for future updates. I’m moving this thread to our Product Feedback section so users can vote on this request.

1 Like

well, i have to say that I’m surprised that a simple peice of functionality that has been part of Asana for so long has been removed.

is there a way we can downgrade to a previous version of the UI?


why would you remove drag-drop functionality? This doesn’t make any sense. you have taken something that took a single movement of the mouse to multiple steps…


Hi @Dan_Shone , @Josh_Feldt , does this not work in your Asana workspace?

Apologies, I missed this.

Yes this works thanks.

1 Like

Thank you for elevating this. It was the only way that I was able to take many steps from one project and duplicate them in another (after first copying the project that I wanted to drag tasks from). This was already tedious, but the only option.

When will this issue be resolved?

Drag and drop from one project to another was important to my workflow, would love if this feature was brought back

1 Like

This works

1 Like

So, basically, we just need to duplicate our projects into the Starred section for now to restore functionality? I work for a sign shop and, once a “Drawings” task is finished, we get final production art ready and move it to either “Work Orders” or “Need To Order” Projects and assign to the appropriate co-worker, which then clears that item from “Drawings.”

As it stands, I can’t even change the project in the main Task pane on the right (not the sidebar). Previously, you could click the Project name in the Task pane and reassign it to a different Project. Now I can only add to another Project, which duplicates the Task, or I can reassign it to another section of the same Project.

*Revised original post to crop out certain info. :wink: