Ability to drag and drop tasks in the new sidebar

yes and No @Brian_Schmidt

right click on the project in the sidebat and add it to starred, then work on the project as normal from the starred section.

re the project, you have to add it to another product before you delete it. however you can still drag and drop it from the starred section.

it’s a massive oversight by Asana, but hopefully one they’ll resolve.

1 Like

Yep, that’s what I meant re: duplicating the Projects into the Starred section. Basically, it creates two instances of the Projects – “Starred” and “Projects” – so now there’s basically two of the same thing in the sidebar: one that works with drag/drop and one that doesn’t. Hopefully they address this, because I’m having to let my boss and co-workers know that they all have to create their own Starred section in the sidebar (since this appears to be user-centric, kind of like Favorites in the Windows Explorer sidebar – since they don’t see the Starred section that I’ve created) to re-enable drag/drop. This is affecting our entire (albeit small) company.

And, yeah, having to “add” to another Project and then delete the original is an extra step and you either have to mark the Task “complete” or delete it… neither of which is accurate/correct for the status of said Project – because it is neither canceled nor complete. :man_shrugging:

i feel your pain!

@Vanessa_N is there any news on if this is going to be re-instated?

Can someone add some more details to this? I don’t understand how to try it. drag and drop was a huge use for me. I can’t believe this has been removed.

right click on the project in the sidebar, then click add to starred:


this will add the project to your starred projects, then when you access the project via starred on the sidebar you can drag and drop as normla.



Please let us know when this will be resolved, hopefully ASAP!

A trivial feature I use all the time, moving tasks between projects has now gone from a 1 second drag-and-drop to a 15 second, type in new project/section, and remove prior project/section. For each one.

Huge miss that this wasn’t included. Have used Asana for 5+ years and use this all the time.

Very surprised that this hasn’t been fixed yet… the starred project fix was helpful for now, but I can’t believe this feature was removed at all. Any ETA on reinstating this?


+1 - it’s really annoying having to manually go in, add to project, and then remove any pre-existing projects it’s part of

This was part of our workflow as well, very frustrating to lose it. However, we can restore the functionality by “starring” the projects we want to drag to, even temporarily. Also I find it strange that the destination project is not highlighted when dragging to it.


New wrinkle: lately unable to drag and drop between certain Starred projects in the sidebar, too. Was working fine until yesterday, I think…? That was the first time a co-worker mentioned problems, and I’ve been able to confirm the issue on my computer as well. Happens in both asana.com via Web browser and in the app.

Dragging to one project does the blue line highlight above (still not fixed to highlight the actual project, eh?), but it ends up uncategorized and we have to search for it. Ends up being loose in the “Recently Added” but not in the actual project we tried to drag it to. Other projects that we have access to won’t even highlight at all (no blue line above).

Just getting worse and worse…


OK, I did stumble across something just now that seems to indicate that it’s a permission thing:

It appears that only Project Admins can drag & drop to projects. Editors cannot, even though, according to the description, Editors “Can add, edit, and delete anything in the project.”

So, this just popped back up again today and I can’t drag things to the Starred sections. Was working fine yesterday.


I also lost the ability to drag-and-drop tasks to Starred Projects a few days ago. Please bring this back. I have several different projects (Brainstorming, Roadmap, In Progress, etc) that very commonly transfer tasks back-and-forth.

At this point, is this a bug, or is this feature intended to be removed? I don’t see why you’d remove a very helpful, functional feature. Is there a technical limitation on the backend you are trying to avoid?


Same problem here, drag-n-drop from one project into another is BROKEN!
I noticed it on Friday (2023-09-08). Checked web browser (Chrome) on Windows and Linux (OpenSUSE), and the Asana Windows application with the same result (feature BROKEN).
As others have said, this is a very useful feature that I use often in my workflow and hope is restored very soon.
Seems like the quality checks on software updates by the Asana QC team should have causght this. :man_shrugging:


causght → caught
(My QC isn’t working very well this morning! :grinning:)

I am also having this challenge. Very very frustrating. I usually bulk select multiple tasks to drag between projects. I am not able to do this.

In the workaround, going to the bottom bar, I can manually edit project or section. But when I do this, it takes the selected tasks and drags in them in backwards order.


Same problem here, functionality is completely broken. It was bad enough having to start the projects to do a basic Asana functionality, but now it is simply not working no matter what you do


I pay thousands of dollars per year for Asana, this is an unacceptable level of customer support.


I’ve dragged and dropped tasks between projects for multiple years now. With the new sidebar, it appears you killed that functionality unless you “star” all your projects. So I went in and starred all my projects just so it was seamless for me to move tasks between projects. Again, I do this ALL THE TIME!! But now in the last few days, I can’t even do this with starred items? Again, asana user for many years and this is a must have. Way too many clicks to go into the task, find the project, assign it, then delete the old project. Please acknowledge and flag as critical bug.

1 Like

The fix for 6 months was starring every project. But now that isn’t working at all.

1 Like