"Your upload was not a usable image"

Briefly describe (1-2 sentences) the Bug you’re experiencing:

When attempting to update the icon for a developer app, I only get an error message:

“Your upload was not a usable image. Choose a PNG, JPEG, or GIF that’s under 5MB and try again.”

I’ve tried this with a variety of images, including some I have used in the past and none have been accepted.

Steps to reproduce:

Browser version:
Chrome Version 74.0.3729.169 (Official Build) (64-bit)

Upload screenshots below:

17

Hi @Kothar thank you for reaching out!

I’m moving this post to the #developersAPI category so our developers can help you with this issue.

@Matt_Bramlage, @Jeff_Schneider or @Joe_Trollo any chance this is something you can help you with?

If there is anything else I can assist you with, please let me know. Have a nice Monday!

2 Likes

Hey @Kothar, sorry to hear you’re having this issue. We will look into it and get back to you. Could you attach the exact file you’re having issues with? That will help us repo it.

Yep, I’ve just checked and this png fails:

ditto

It’s only 70x70 pixels, but I’ve also tried other images and larger versions of this image with no success.

For example, the same image resampled to 120x120 pixels gives the same error:
ditto120

As does this logo which I have used in the past and is already assigned to an existing developer app:
logo_square

Same for me with this image. PNG, 8Ko, 128x128px

mini

Thank you for providing the additional details, @Kothar. Our API team is investigating. I will let you know what we find out.

@Kothar, this is definitely a bug and we are not yet certain what’s causing it. Sorry for the frustration and inconvenience. The good news is that we are just about to role out a new version of the developer console (that doesn’t have this bug). You should be using the new console next week.

1 Like

Thanks Jeff, I’ll give it another go next week!

Hey @Kothar, our API team fixed the bug ahead of the new console release. It should work for you now. Can you confirm? Sorry again for the issue.

1 Like

Yep! That works fine now, thanks for looking into it.

Also worked for me, thanks.