Webhooks not firing

For more than an hour now, our webhooks are not firing.
We receive a lot of webhooks normally and we did not change any code on our side.
Anybody else has the same issue?

Thank you.

Facing the same issue ‘Events are not coming from asana’ from last hour or so. It was working fine few hours back.

Thanks,
Mukul

Same here. :cry:

Same here. Last event was sent 10:16 UTC today. Since then nothing.

Hi everyone, thanks for reporting this issue and sorry for the trouble here!

Our engineering team are currently investigating, and we hope to have this resolved very shortly. In the meantime, you can monitor updates here: trust.asana.com.

I’ve moved this thread to our bug category and I’ll also make sure to keep this thread updated as soon as we have more information.

FYI:
https://status.asana.com/incidents/9g58yxc4lzlk

A fix has been implemented and we are monitoring the results.

Posted 4 minutes ago. Jun 16, 2020 - 13:48 UTC

2 Likes

Thanks for sharing the information here @Phil_Seeman! :clap: I was just going to post an update but you were faster :sweat_smile:

1 Like

@Joe_Trollo @Ross_Grambo @Marie @Emily_Roman
I am currently seeing issues where it appears some webhooks are being delivered and some not. Please advise…

2 Likes

Thanks for the update @Phil_Seeman, I’m checking this with our team and will keep you posted here once they get back to me!

1 Like

Thanks, @Marie. My apps’ webhooks are definitely all not firing at present.

1 Like

Thanks for the follow-up @Phil_Seeman, our team is still looking into this, I’ll keep you posted as soon as I have an update!

Appears to be working again - for now… :worried:

1 Like

@Joe_Trollo @Ross_Grambo
Can you guys supply a post-mortem for this outage when you’re able? Thanks much!

1 Like

@Joe_Trollo @Ross_Grambo @Jeff_Schneider @Marie @Emily_Roman

Hey all,

Actually I believe this is still an active problem - Flowsana webhooks seem to work one minute, then not the next. They appear to work for a while and then don’t, and then do again. Can you provide some input? Thanks.

We have someone working on it now. I’ll relay any updates I hear. :confused:

2 Likes

Hi everyone, sorry it’s taken us so long to respond here—this was a gnarly incident to resolve. We believe we found the root cause and have fixed the issue, but we’ll be monitoring our systems closely for the next few hours to ensure it doesn’t come back. All webhooks and event streams should be operating normally now, and you might be receiving “old” events as our systems work through the backlog. Unfortunately, events closer to the start of the incident will have been dropped and cannot be delivered at this point. If you continue to encounter issues, please let us know here and we’ll investigate further.

We’ll be posting a summary of the incident and a list of follow-ups sometime tomorrow. Thank you for your patience!

5 Likes

Briefly describe (1-2 sentences) the Bug you’re experiencing:
My app is having troubles receiving triggers from Asana webhooks
Steps to reproduce:

Browser version:

Upload screenshots below:

Hi @Konstantin_Kalashnik and thanks for the report. i’ve merged your post with the existing thread we already had on this topic. Please see above the latest update from our team!

1 Like

Hi all—I’ve just posted our summary of the incident in the Platform News category of the forum. You can head there to read more and ask any lingering questions you have.

1 Like

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.