Webhook for Poject is not working anymore

@Phil_Seeman, @Bastien_Siebman

Here I have created webhook for project to synchronize task to KanbanTool. After creating webhook I got first response when I created task and it worked perfectly. But when I create new task after some time in same project than it didn’t work out. When I delete that webhook and create again new webhook than it worked fine for new task that I created after creating webhook but I want to know why it loose connection when I create new task. Also when I create second task it gave me first task response instead of second task. I have gone through API documentation multiple times but I can’t found any helpful resources.

Can you please provide me sample code to manage this functionality ? Or Can you please guide me how to get consistent response after creating webhook ?

Appreciate your help

See my reply in the other thread where you posted about this issue.

This piece of info is further evidence to support the hypothesis I made in the other thread, that you’re not returning the proper values from your webhook routine - because if Asana doesn’t receive back a confirmation that you successfully received its webhook, it will re-send that same webhook a number of times, before eventually giving up.