We upgraded to Premium a couple of months ago, but premium functions still not working. Asana support doesn't get back to us


I cannot believe we went to the Premium version back in February and today we still can’t use the Premium functions. I have contacted Asana support thru the contact form and still no response.
Anyone out there had a similar situation?


Hey Fred,

Sorry about this - it looks like someone’s working on your case right now. I’m not quite sure what happened with your first email to support, but our team tries to respond to everyone as quickly as possible. It might have got caught up in a filter - we’ll see if we can figure that out.

In any case, sometimes there’s confusion around the difference between upgrading teams and Workspaces vs. Organizations, as only Organizations have Admin features, and with a premium team, the premium features won’t extend to the entire Organization.

So if anyone out there’s having a similar issue, contact support and they’ll help you get it straightened out.