Unfurl in Slack only works in Asana channel

Briefly describe (1-2 sentences) the Bug you’re experiencing:
Unfurl in Asana-Slack app doesn’t work.

Steps to reproduce:

  1. install Asana-Slack app
  2. Authorize
  3. Change settings so that Display Links Previews is set to “On for public and private links”
  4. Paste an Asana task link into Asana channel. Notice unfurl works just fine.
  5. Paste same Asana task link into any other channel. Notice unfurl doesn’t work.

Deauthorizing and re-authorizing doesn’t work per this:

Browser version: most recent Chrome as of today

Upload screenshots below:

Hi @Suraj_Gupta and thanks for the report. Could you answer these few questions to help us investigate this issue?

  1. Could you please share screenshots of your settings and tests you’ve run?
  2. Is this happening with multiple channels?
  3. Have you tried to uninstall and re-install the Slack integration?

Looking forward to your reply!

Hi Marie,

Happy to! Will knock-out all three questions with this:

  1. Uninstall Asana-Slack integration
  2. Shutdown Windows Slack client
  3. Run Windows Slack client (in case that cleared anything out)
  4. Shutdown Windows Slack client
  5. Reinstall Asana-Slack integration
  6. Run Windows Slack client
  7. In Asana channel, follow prompts to confirm Domain turn on Notifications
  8. run /asana settings, change settings (see pic attached) -
  9. Paste link to asana task - observe unfurl (same pic)
  10. Change to any other channel and paste same link
  11. Observe no unfurl (see next reply for screenshot - this forum won’t let me put two screenshots into the same reply)

Thanks for the follow-up @Suraj_Gupta, I’ve gone ahead and filed a task for our team to investigate, I’ll be in touch as soon as I have an update on my end!

Hi Marie,
I’m having the same issue as Suraj, but for me it won’t even unfurl the link in the Asana app channel. I tried the exact same steps Suraj outlined, but nothing helped.
Can you please also let me know if there is a fix for this issue?
Thank you

I don’t have an update just yet, but I’ll keep you posted as soon as I do!

I am seeing similar behavior in my workspace; link unfurling appears to no longer be working in any channel.

However, for me it won’t even work in the Asana channel. When I post an Asana link there, it just replies with the “Quick Actions” and “available commands” help prompt (the one that says " Hi @jon , here are some ways you can use Asana for Slack to manage your work.") So link unfurling for us is broken everywhere.

@Suraj_Gupta, @Romy_Bundy and @Jonathan_Flowers,

Our team has pushed an update in the last few hours that should fix this issue. Could you please re-authorise the app using https://slack-server.asana.plus/auth/gbp and let me know if the issue persists?

@Suraj_Gupta, I’m aware you’ve already followed this step, but I believe you did before our team pushed the update, so if you could give it another go it would be great!

Looking forward to your replies!

I just re-authorized the app and can confirm link unfurling is working for me. Thank you!

Fabulous, thank you so much for keeping me posted :slight_smile: