Unable to find user IDs with app.asana.com/api/1.0/user

Briefly describe (1-2 sentences) the Bug you’re experiencing:
I get the following message when trying to find user IDs: {“errors”:[{“message”:“No matching route for request”,“help”:“For more information on API status codes and how to handle them, read the docs on …”}]}

I tried to add a limit parameter and got the same result: https://app.asana.com/api/1.0/teams/…/users?limit=2

I am trying to create a Zap in Zapier, but it cannot find any of the users so I can assign a task, was able to recreate the message by going to /api/1.0/users

Steps to reproduce:

I can only add one link per post as a new user…so navigate to the link above

Browser version:

Google Chrome Version 96.0.4664.55 and
Safari Version 15.0

Upload screenshots below:
(only able to upload one screenshot, so I chose the one from Zapier. It’s the same message though.


…)

Hi @Kirsten_Runyan and welcome to the forum,

I know it’s a bit tough with the limit of one screenshot per post, but can you provide some additional detail about what you’re trying to do? I’m afraid it’s confusing as it currently stands because the screenshot shows a completely different error (too many results) than what you mention in your text (no matching route).

“Too many results” means your query is returning more than 100 results and as I recall , Zapier can’t handle pagination which Asana requires for more than 100, so you’re out of luck using Zapier with a query returning > 100 results.

“No matching route” means the URL you’re attempting to send to the Asana API is not a valid Asana API endpoint.

1 Like

Hi @Phil_Seeman - really appreciate the feedback!

I probably should have chosen a different screenshot. I was hoping to bypass the issue with Zapier by directly adding the User ID to the field (I’ve had that work…sometimes) but my real issue is that I can’t get the user IDs at all from app.asana.com/api/1.0/users

What’s interesting is when I add a limit parameter, I get the same message I am seeing Zapier. (We aren’t a large organization, so I don’t know if our asana workspace has more than 100 users…it may though with added clients/freelancers)

@Phil_Seeman here’s one more screenshot for with the limit parameter

My first post was flagged for some reason… here’s the screenshot. My issue is not being able to search User IDs at all.

Yeah, I’m not sure why those posts got flagged; @Forum-team could you investigate and unflag those?

@Kirsten_Runyan, as the error message says, you should add the workspace gid: https://app.asana.com/api/1.0/users?limit=100&workspace={workspace gid}

Thank you so much @Phil_Seeman!! I got it to work!!

1 Like

Hi @Andrew_Smith4,

I found a solution by including the workspace grid like @Phil_Seeman indicated in his comment. If you don’t know your workspace gid you can find it by navigating to https://app.asana.com/api/1.0/users/me (which will give you all the workspaces you are associated with…make sure you’re logged into asana first).

You can then use pagination to get users if you have more than 100 (Asana)

I also realized I can grab the user id from a task that’s assigned to the user I want to assign it to via Zapier (that was a bit easier than using pagination). I got around the issue in Zapier by directly inputting the user id via the custom field.

Hopefully that helps. Good luck!

1 Like