Unable to connect to Onedrive with Microsoft business account

I can’t connect to Onedrive with my Microsoft Business account. I get this error: “You don’t have a Microsoft account”, but I definitely have a business account. In addition, it works fine when I try to sign in with my personal Microsoft account. Anyone else with this problem?


I’m having the same issue, and unfortunately have had no luck troubleshooting this yet. Can’t tell if this is a Microsoft issue or Asana. I’m able to attach files from OneDrive/Sharepoint just fine within a task, but adding a rule to upload a document to OneDrive isn’t allowing me to connect.

1 Like

Same issue.

1 Like

I am experiencing this issue, too.

1 Like

Yeah, I have the same issue. It seems you can only connect a private OneDrive and not a OneDrive for Business. Would be great if this could be fixed quickly.


same for me, anoying…

1 Like

Experiencing the same issue here. Hopefully there is a solution soon.

1 Like

It seems that only the Safari internet browser solves the problem above. I still love to see a solution for the rest of the internet browsers.

Very disappointed that I cannot connect my Microsoft business account to Asana. If it works for Personal OneDrive, it should work for business OneDrive. :angry:


Just standard procedure? Just tried to integrate via Safari for a Rule and it didn’t work.

1 Like

Doesn’t work on my end either, I am having the same problem

1 Like

They mention on the “OneDrive + Asana” page that the OneDrive and SharePoint integration doesn’t support “work or school” accounts. I can see that personal OneDrive accounts are common, but it seems strange to pretend that they have SharePoint integration. I can’t imagine that many people outside of work use SharePoint. Regardless, it would help my company if you fixed the integration to work with work Microsoft accounts.

I suppose this is another growing pain as Asana tries to target more enterprise customers rather than small businesses.


Having the same issue. Really a bummer that Asana is primarily a business-focused product but doesn’t support Sharepoint or OneDrive for Business. Please fix this ASAP!

1 Like

I thought I was going crazy until I read these comments! This is very disappointing and really hope Asana fixes this soon. The only workaround I have found is to copy the file link from your OneDrive business acct and add it as a hyperlink in the text box on a task.

Same issue. How could we get an answer from Asana team?

The integration is also not working at all in the Asana app. Even when I just try to add a file to a task, I get an error message saying that my microsoft login does not exist, which is obviously does because I am able to upload files from the browser version.

Nthing wishing this would connect with work OneDrive accounts. I thought this might be the answer to quickly move large numbers of photos as there is no batch download option to files submitted via forms, but it’s another road block.

Does anyone know if Asana has commented on this and have a plan to fix it?

I’ve recently invested a lot of time and then the cost of signing up to various service like Asana Business, MS OneDrive/Teams, Make.com and others. Trying to improve processes and automate things. I would like to connect our systems together to make life easier. Just spent AGES transferring all my company data into OneDrive.

So obviously am really surprised Asana advertise it can connect to OneDrive but actually it can’t (except for personal OneDrive but not sure why any business would want that).


1 Like

I am an Asana user from Japan.
I have the same problem.
This problem should be solved as soon as possible, but it still seems to be neglected.
When I contacted the Japanese sales representative, he replied that Asana is aware of this problem and is working on a solution, but he did not give any milestones, so I do not have much hope.
I sincerely hope that your voice will reach Asana’s development team.

same issue, i would also love for this to be possible!